# CVE-2026-48916: Jenkins LDAP Plugin follows LDAP referrals

> Attackers can exploit LDAP referral following to perform Server-Side Request Forgery, potentially accessing internal resources or bypassing network restrictions.

- **Severity:** Medium 6.6 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 May 2026
- **Updated:** 27 May 2026
- **Also known as:** GHSA-fmjp-mw89-c6h6

## What is CVE-2026-48916?

CVE-2026-48916 is a medium-severity server-side request forgery vulnerability in Jenkins LDAP Plugin, published on 27 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Jenkins LDAP Plugin 807.v7d7de30930cf and earlier follows LDAP referrals.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-48916?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:ldap. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:ldap` | Maven | All versions | 807.809.vd3a |
| `org.jenkins-ci.plugins:ldap` | Maven | All versions | 807.809.vd3a |

Products: Jenkins Ldap.

## How do I fix CVE-2026-48916?

Upgrade org.jenkins-ci.plugins:ldap to 807.809.vd3a or later.

## Is CVE-2026-48916 being exploited?

There is no known exploitation of CVE-2026-48916 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins LDAP Plugin

- [CVE-2026-48917](https://insights.sbomify.com/CVE-2026-48917/): Jenkins LDAP Plugin deserializes data from LDAP referrals without validation (medium 6.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48916 and fix it if it is affected.

What it is: CVE-2026-48916 is a medium-severity server-side request forgery vulnerability in Jenkins LDAP Plugin, published on 27 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-48916 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:ldap (Maven): affected all versions; fixed in 807.809.vd3a
- org.jenkins-ci.plugins:ldap (Maven): affected all versions; fixed in 807.809.vd3a

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48916/ (Markdown: https://insights.sbomify.com/CVE-2026-48916/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48916
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48916
- OSV: https://osv.dev/vulnerability/CVE-2026-48916

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48916/
Summaries are generated and may contain mistakes; the official description above is the record.
