# CVE-2026-48936: Security feature bypass in node

> Attackers can bypass network permission restrictions to start local servers via Unix sockets in Node.js.

- **Severity:** Low 3.3 (`CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Jun 2026
- **Updated:** 26 Jun 2026
- **Also known as:** BIT-node-2026-48936, BIT-node-min-2026-48936, GHSA-hwhp-f859-r728, MINI-mpq4-f99r-p22w, UBUNTU-CVE-2026-48936

## What is CVE-2026-48936?

CVE-2026-48936 is a low-severity vulnerability in Nodejs Node.js, published on 26 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A flaw in Node.js Permission API can cause a local server to be started (via a Unix domain socket), even without the `--allow-net` permission.

This vulnerability affects one supported release line: **Node.js 26**.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-48936?

2 open source packages ship an affected version, including node and node-min. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `node` | Bitnami | From 26.3.0 | 26.3.1 |
| `node-min` | Bitnami | From 26.3.0 | 26.3.1 |

Products: Nodejs Node.js.

## How do I fix CVE-2026-48936?

Upgrade node to 26.3.1 or later.

## Is CVE-2026-48936 being exploited?

There is no known exploitation of CVE-2026-48936 in the wild and no public exploit code.

## Other vulnerabilities in Nodejs Node.js

- [CVE-2023-32002](https://insights.sbomify.com/CVE-2023-32002/): Security feature bypass in Node (critical 9.8)
- [CVE-2016-6303](https://insights.sbomify.com/CVE-2016-6303/): Integer overflow in n/a (critical 9.8)
- [CVE-2017-15896](https://insights.sbomify.com/CVE-2017-15896/): Security feature bypass in Node.js (critical 9.1)
- [CVE-2018-7160](https://insights.sbomify.com/CVE-2018-7160/): Server-side request forgery in Node.js (high 8.8)
- [CVE-2018-12120](https://insights.sbomify.com/CVE-2018-12120/): Misconfiguration in Node.js (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48936 and fix it if it is affected.

What it is: CVE-2026-48936 is a low-severity vulnerability in Nodejs Node.js, published on 26 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-48936 in the wild and no public exploit code.

Affected packages and fixed versions:
- node (Bitnami): affected from 26.3.0; fixed in 26.3.1
- node-min (Bitnami): affected from 26.3.0; fixed in 26.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48936/ (Markdown: https://insights.sbomify.com/CVE-2026-48936/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48936
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48936
- OSV: https://osv.dev/vulnerability/CVE-2026-48936

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48936/
Summaries are generated and may contain mistakes; the official description above is the record.
