{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-48961 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-48961 is a high-severity denial of service vulnerability in PMQS IO::Compress, published on 27 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-48961 and fix it if it is affected.\n\nWhat it is: CVE-2026-48961 is a high-severity denial of service vulnerability in PMQS IO::Compress, published on 27 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-48961 in the wild and no public exploit code.\n\nAffected product: PMQS IO::Compress. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-48961/ (Markdown: https://insights.sbomify.com/CVE-2026-48961/index.md)","id":"CVE-2026-48961","markdown":"https://insights.sbomify.com/CVE-2026-48961/index.md","name":"CVE-2026-48961","record":{"aliases":["BELL-CVE-2026-48961","DEBIAN-CVE-2026-48961","ECHO-3bd6-6520-0759","GHSA-hjrw-gmwj-xc9c","ROOT-OS-DEBIAN-11-CVE-2026-48961","UBUNTU-CVE-2026-48961","openSUSE-SU-2026:10969-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Perl IO::Compress library","requires_auth":"none","summary":"A bug in the zipdetails CLI tool causes a crash when processing specific ZIP files, leading to denial of service for users of the tool.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"CPANSec","cpe":[],"cvss":{"score":7.3,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-755","name":"Improper Handling of Exceptional Conditions"}],"description":"IO::Compress versions from 2.207 before 2.220 for Perl ship a zipdetails CLI tool that crashes with undefined subroutine on Info-ZIP Unix Extra Field with 8-byte UID or GID.\n\nWhen decode_ux() in bin/zipdetails handles an Info-ZIP Unix Extra Field (tag 0x7875) with UID Size or GID Size set to 8, causing zipdetails to decode an 8-byte UID or GID value, it dispatches through decodeLitteEndian(), which calls a misnamed helper unpackValueQ. The actual function defined in the same file is unpackValue_Q (with underscore); the call raises 'Undefined subroutine \u0026main::unpackValueQ' and the script exits with status 255.\n\nLibrary callers of IO::Compress and IO::Uncompress are not affected; the defect is in the bundled CLI tool.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in IO::Compress","id":"CVE-2026-48961","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":1,"n_references":2,"next":{"headline":"Code injection in IO::Compress","id":"CVE-2026-48962"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.220.0-2.1"],"introduced":["0"],"last_affected":[],"package":"perl-IO-Compress","purl":"pkg:rpm/opensuse/perl-IO-Compress\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10969-1"}],"prev":{"headline":"IO::Uncompress::Unzip versions before 2.220 for Perl allow CPU exhaustion via per-byte read loop in fastForward","id":"CVE-2026-48959"},"products":["IO::Compress"],"published":"2026-05-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-29","vendors":["PMQS"]},"summary":"A bug in the zipdetails CLI tool causes a crash when processing specific ZIP files, leading to denial of service for users of the tool.","url":"https://insights.sbomify.com/CVE-2026-48961/"}