{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-48980 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-48980 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-48980 is a medium-severity authentication bypass vulnerability in mcdope pam_usb, published on 18 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-48980 and fix it if it is affected.\n\nWhat it is: CVE-2026-48980 is a medium-severity authentication bypass vulnerability in mcdope pam_usb, published on 18 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-48980 in the wild and no public exploit code.\n\nAffected product: mcdope pam_usb. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-48980/ (Markdown: https://insights.sbomify.com/CVE-2026-48980/index.md)","id":"CVE-2026-48980","markdown":"https://insights.sbomify.com/CVE-2026-48980/index.md","name":"CVE-2026-48980","record":{"aliases":["GHSA-qr83-mf3h-fvqr"],"analysis":{"component_type":"operating_system","fix_type":"upgrade","impacts":["privilege_escalation","security_bypass"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Linux PAM module","requires_auth":"low_privilege","summary":"Local attackers can bypass hardware authentication in pam_usb by manipulating environment variables, potentially gaining unauthorized access or privileges.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-807","name":"Reliance on Untrusted Inputs in a Security Decision"},{"id":"CWE-454","name":"External Initialization of Trusted Variables or Data Stores"}],"description":"pam_usb provides hardware authentication for Linux using removable media. In versions prior to 0.9.2,  getenv() environment variables XRDP_SESSION, DISPLAY and TMUX allow environment variable injection into local-check logic. These environment variables influence whether a current session is local or remote, and a PAM module that runs in the context of setuid binaries (sudo, su), getenv() returns attacker-controlled values whenever the process environment has been manipulated by a local user. This issue has been fixed in version 0.9.2.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"pam_usb: getenv() used in PAM context allows environment variable injection into local-check logic","id":"CVE-2026-48980","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":0,"n_references":2,"next":{"headline":"pam_usb: xmlReadFile flags=0 permits XXE network entity fetching in conf.c","id":"CVE-2026-48981"},"packages":[],"prev":{"headline":"PHP Standard Library: HTTP/2 server-side missing content-length validation enables request smuggling","id":"CVE-2026-48979"},"products":["pam_usb"],"published":"2026-06-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-06-18","vendors":["mcdope"]},"summary":"Local attackers can bypass hardware authentication in pam_usb by manipulating environment variables, potentially gaining unauthorized access or privileges.","url":"https://insights.sbomify.com/CVE-2026-48980/"}