# CVE-2026-48980: pam_usb: getenv() used in PAM context allows environment variable injection into local-check logic

> Local attackers can bypass hardware authentication in pam_usb by manipulating environment variables, potentially gaining unauthorized access or privileges.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 18 Jun 2026
- **Updated:** 18 Jun 2026
- **Also known as:** GHSA-qr83-mf3h-fvqr

## What is CVE-2026-48980?

CVE-2026-48980 is a medium-severity authentication bypass vulnerability in mcdope pam_usb, published on 18 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

pam_usb provides hardware authentication for Linux using removable media. In versions prior to 0.9.2,  getenv() environment variables XRDP_SESSION, DISPLAY and TMUX allow environment variable injection into local-check logic. These environment variables influence whether a current session is local or remote, and a PAM module that runs in the context of setuid binaries (sudo, su), getenv() returns attacker-controlled values whenever the process environment has been manipulated by a local user. This issue has been fixed in version 0.9.2.

Weakness: CWE-807 (Reliance on Untrusted Inputs in a Security Decision), CWE-454 (External Initialization of Trusted Variables or Data Stores)

## Which versions are affected by CVE-2026-48980?


## How do I fix CVE-2026-48980?

No fix has been published for CVE-2026-48980 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-48980 being exploited?

There is no known exploitation of CVE-2026-48980 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48980 and fix it if it is affected.

What it is: CVE-2026-48980 is a medium-severity authentication bypass vulnerability in mcdope pam_usb, published on 18 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-48980 in the wild and no public exploit code.

Affected product: mcdope pam_usb. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48980/ (Markdown: https://insights.sbomify.com/CVE-2026-48980/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48980
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48980
- OSV: https://osv.dev/vulnerability/CVE-2026-48980

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48980/
Summaries are generated and may contain mistakes; the official description above is the record.
