# CVE-2026-48998: guzzlehttp/psr7 has Host Confusion via Authority Reinterpretation

> Attackers can bypass host validation in Guzzle PSR7 by crafting malformed Host headers, potentially causing requests to be sent to unintended hosts.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jun 2026
- **Updated:** 11 Jun 2026
- **Also known as:** DEBIAN-CVE-2026-48998, GHSA-34xg-wgjx-8xph, MINI-34h9-3f4r-3hr5, MINI-3q3r-484q-wwj8, MINI-3v9r-v6hg-52w6, MINI-84cp-2928-pfp9, MINI-fgmj-m36x-2prr, MINI-hg25-8whq-mgqc, MINI-hqg2-c5mq-hrqq, UBUNTU-CVE-2026-48998

## What is CVE-2026-48998?

CVE-2026-48998 is a medium-severity server-side request forgery vulnerability in guzzle psr7, published on 11 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

guzzlehttp/psr7 is a PSR-7 HTTP message library implementation in PHP. Versions prior to 2.10.2 contain improper Host header validation when parsing raw HTTP request messages and when deriving a server request URI from server variables. An attacker can provide a malformed Host header containing URI authority delimiters, such as `trusted.example@evil.example`. When the Host value is used to construct a URI, the malformed value can be reinterpreted as URI userinfo and host. This can cause the PSR-7 request URI host to differ from the original Host header value. Applications are affected if they parse attacker-controlled raw HTTP requests with `GuzzleHttp\Psr7\Message::parseRequest()` or the legacy 1.x `GuzzleHttp\Psr7\parse_request()` function, or if they build server requests from attacker-controlled server variables, then rely on the resulting URI host for routing, allow-list checks, or forwarding decisions. In affected forwarding or gateway scenarios, this may cause requests or credentials to be sent to an unintended host. The issue is patched in `2.10.2`. `1.x` is end-of-life and will not receive a patch. Some workarounds are available. Validate the `Host` header as `uri-host [ ":" port ]` before calling `Message::parseRequest()` or legacy `parse_request()` on untrusted HTTP request data, or before deriving routing and forwarding decisions from a parsed request URI. Reject Host values containing userinfo, path, query, or fragment delimiters.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-48998?

2 open source packages ship an affected version, including guzzlehttp/psr7. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `guzzlehttp/psr7` | Packagist | All versions | 2.10.2 |
| `guzzlehttp/psr7` | Packagist | All versions | 2.10.2 |

Products: Guzzlephp Psr-7.

## How do I fix CVE-2026-48998?

Upgrade guzzlehttp/psr7 to 2.10.2 or later.

## Is CVE-2026-48998 being exploited?

There is no known exploitation of CVE-2026-48998 in the wild and no public exploit code.

## Other vulnerabilities in guzzle psr7

- [CVE-2026-49214](https://insights.sbomify.com/CVE-2026-49214/): guzzlehttp/psr7 has CRLF Injection via URI Host Component (medium 5.3)
- [CVE-2026-55766](https://insights.sbomify.com/CVE-2026-55766/): guzzlehttp/psr7: CRLF Injection in HTTP Start-Line Serialization (medium 4.8)
- [CVE-2026-59882](https://insights.sbomify.com/CVE-2026-59882/): guzzlehttp/psr7: Host Confusion via Weak URI Host Validation (medium 4.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48998 and fix it if it is affected.

What it is: CVE-2026-48998 is a medium-severity server-side request forgery vulnerability in guzzle psr7, published on 11 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-48998 in the wild and no public exploit code.

Affected packages and fixed versions:
- guzzlehttp/psr7 (Packagist): affected all versions; fixed in 2.10.2
- guzzlehttp/psr7 (Packagist): affected all versions; fixed in 2.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48998/ (Markdown: https://insights.sbomify.com/CVE-2026-48998/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48998
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48998
- OSV: https://osv.dev/vulnerability/CVE-2026-48998

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48998/
Summaries are generated and may contain mistakes; the official description above is the record.
