CVE-2026-49009 Path traversal in n/a

Low 3.1 Published Updated

An attacker can exploit a directory traversal vulnerability in Mender Server to read arbitrary files from the server.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-49009?

CVE-2026-49009 is a low-severity path traversal vulnerability in n/a, published on 27 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Northern.tech Mender Server v4.1.0, v4.0.1 and below, and fixed in v4.1.1 and v4.0.2 allows Directory Traversal.

Weakness: CWE-22

Which versions are affected by CVE-2026-49009?

How do I fix CVE-2026-49009?

No fix has been published for CVE-2026-49009 yet. Limit exposure of the affected software until one is available.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2026-49009 being exploited?

There is no known exploitation of CVE-2026-49009 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

Sources

Also known as GHSA-96xf-q5p5-mc93.

Is CVE-2026-49009 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free