# CVE-2026-49014: GDAL: scanForGeometryContainers in the netCDF driver allows code execution via a stack-based buffer overflow

> A stack-based buffer overflow in GDAL's netCDF driver allows arbitrary code execution when processing crafted files.

- **Severity:** High 7.4 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 May 2026
- **Updated:** 27 May 2026
- **Also known as:** AZL-88380, BIT-gdal-2026-49014, DEBIAN-CVE-2026-49014, ECHO-d542-982c-16cf, GHSA-wphc-7cm7-8mf7, JLSEC-2026-766, PYSEC-2026-193, UBUNTU-CVE-2026-49014

## What is CVE-2026-49014?

CVE-2026-49014 is a high-severity memory corruption vulnerability in GDAL, published on 27 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

In GDAL 3.1.0 through 3.13.0, scanForGeometryContainers in the netCDF driver allows code execution via a stack-based buffer overflow. It reads a geometry attribute into a fixed-size stack buffer without validating the attribute length. The attacker embeds the exploit as an oversized geometry attribute in a crafted NetCDF file. This achieves arbitrary code execution on the server running GDAL. This is in frmts/netcdf/netcdfsg.cpp.

Weakness: CWE-121 (Stack-based Buffer Overflow)

## Which versions are affected by CVE-2026-49014?

4 open source packages ship an affected version, including gdal. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gdal` | Bitnami | From 3.1.0 | 3.13.1 |
| `gdal` | PyPI | From 3.1.0 | 3.13.1 |
| `gdal` | PyPI | From 3.1.0 | 3.13.1 |
| `gdal` | PyPI | From 3.1.0 | 3.13.1 |

Products: Osgeo Gdal.

## How do I fix CVE-2026-49014?

Upgrade gdal to 3.13.1 or later.

## Is CVE-2026-49014 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49014 exists.

## Other vulnerabilities in GDAL

- [CVE-2019-25050](https://insights.sbomify.com/CVE-2019-25050/): Memory corruption in n/a (high 7.8)
- [CVE-2025-29480](https://insights.sbomify.com/CVE-2025-29480/): Memory corruption in n/a (medium 5.5)
- [CVE-2026-8212](https://insights.sbomify.com/CVE-2026-8212/): OSGeo gdal SWapi.c SWSDfldsrch heap-based overflow (medium 4.8)
- [CVE-2026-8213](https://insights.sbomify.com/CVE-2026-8213/): OSGeo gdal Grid File GDapi.c GDSDfldsrch heap-based overflow (medium 4.8)
- [CVE-2026-8084](https://insights.sbomify.com/CVE-2026-8084/): OSGeo gdal HDF-EOS Grid File SWapi.c memmove out-of-bounds (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49014 and fix it if it is affected.

What it is: CVE-2026-49014 is a high-severity memory corruption vulnerability in GDAL, published on 27 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49014 exists.

Affected packages and fixed versions:
- gdal (Bitnami): affected from 3.1.0; fixed in 3.13.1
- gdal (PyPI): affected from 3.1.0; fixed in 3.13.1
- gdal (PyPI): affected from 3.1.0; fixed in 3.13.1
- gdal (PyPI): affected from 3.1.0; fixed in 3.13.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49014/ (Markdown: https://insights.sbomify.com/CVE-2026-49014/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49014
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49014
- OSV: https://osv.dev/vulnerability/CVE-2026-49014

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49014/
Summaries are generated and may contain mistakes; the official description above is the record.
