CVE-2026-49042 Apache Camel: langchain4j-tools: filter tool argument headers against declared parameters
Attackers can bypass header filtering in langchain4j-tools, potentially exposing sensitive data or bypassing security controls in Apache Camel applications.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-49042?
CVE-2026-49042 is a high-severity vulnerability in Apache Camel, published on 6 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Improper Input Validation vulnerability in Apache Camel.
This issue affects Apache Camel: from 4.8.0 through 4.18.2, from 4.19.0 through 4.20.0.
Users are recommended to upgrade to version 4.18.3, 4.21.0, which fixes the issue.
Weakness: CWE-20
Which versions are affected by CVE-2026-49042?
12 open source packages ship an affected version, including org.apache.camel:camel-langchain4j-agent, org.apache.camel:camel-langchain4j-tools and org.apache.camel:camel-spring-ai-tools. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.camel:camel-langchain4j-agent Maven | From 4.19.0 | 4.21.0 |
org.apache.camel:camel-langchain4j-agent Maven | From 4.19.0 | 4.21.0 |
org.apache.camel:camel-langchain4j-agent Maven | From 4.8.0 | 4.18.3 |
org.apache.camel:camel-langchain4j-agent Maven | From 4.8.0 | 4.18.3 |
org.apache.camel:camel-langchain4j-tools Maven | From 4.19.0 | 4.21.0 |
org.apache.camel:camel-langchain4j-tools Maven | From 4.19.0 | 4.21.0 |
6 more packages
org.apache.camel:camel-langchain4j-tools Maven | From 4.8.0 | 4.18.3 |
org.apache.camel:camel-langchain4j-tools Maven | From 4.8.0 | 4.18.3 |
org.apache.camel:camel-spring-ai-tools Maven | From 4.19.0 | 4.21.0 |
org.apache.camel:camel-spring-ai-tools Maven | From 4.19.0 | 4.21.0 |
org.apache.camel:camel-spring-ai-tools Maven | From 4.8.0 | 4.18.3 |
org.apache.camel:camel-spring-ai-tools Maven | From 4.8.0 | 4.18.3 |
Products include Apache Camel.
How do I fix CVE-2026-49042?
Upgrade org.apache.camel:camel-langchain4j-agent to a fixed version for your release line: 4.21.0 or 4.18.3.
Is CVE-2026-49042 being exploited?
There is no known exploitation of CVE-2026-49042 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Apache Camel
- CVE-2026-33453 Apache camel-coap allows header injection that can lead to remote code execution
- CVE-2026-40453 Apache Camel has an incomplete fix for CVE-2025-27636
- CVE-2026-80351 Apache Camel K: Camel K Tenant repositories reach Maven execution inside operator pod
- CVE-2026-80352 Apache Camel K: Camel K Master trait serviceAccountName YAML injection lets CR author apply arbitrary objects
- CVE-2026-71300 Apache Camel: Camel-Atmosphere-Websocket: WebSocket dispatch header injection
Sources
Also known as GHSA-hh8r-75r6-qrg9.