# CVE-2026-49042: Apache Camel: langchain4j-tools: filter tool argument headers against declared parameters

> Attackers can bypass header filtering in langchain4j-tools, potentially exposing sensitive data or bypassing security controls in Apache Camel applications.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jul 2026
- **Updated:** 6 Jul 2026
- **Also known as:** GHSA-hh8r-75r6-qrg9

## What is CVE-2026-49042?

CVE-2026-49042 is a high-severity vulnerability in Apache Camel, published on 6 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Input Validation vulnerability in Apache Camel.

This issue affects Apache Camel: from 4.8.0 through 4.18.2, from 4.19.0 through 4.20.0.

Users are recommended to upgrade to version 4.18.3, 4.21.0, which fixes the issue.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-49042?

12 open source packages ship an affected version, including org.apache.camel:camel-langchain4j-agent, org.apache.camel:camel-langchain4j-tools and org.apache.camel:camel-spring-ai-tools. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.camel:camel-langchain4j-agent` | Maven | From 4.19.0 | 4.21.0 |
| `org.apache.camel:camel-langchain4j-agent` | Maven | From 4.19.0 | 4.21.0 |
| `org.apache.camel:camel-langchain4j-agent` | Maven | From 4.8.0 | 4.18.3 |
| `org.apache.camel:camel-langchain4j-agent` | Maven | From 4.8.0 | 4.18.3 |
| `org.apache.camel:camel-langchain4j-tools` | Maven | From 4.19.0 | 4.21.0 |
| `org.apache.camel:camel-langchain4j-tools` | Maven | From 4.19.0 | 4.21.0 |
| `org.apache.camel:camel-langchain4j-tools` | Maven | From 4.8.0 | 4.18.3 |
| `org.apache.camel:camel-langchain4j-tools` | Maven | From 4.8.0 | 4.18.3 |
| `org.apache.camel:camel-spring-ai-tools` | Maven | From 4.19.0 | 4.21.0 |
| `org.apache.camel:camel-spring-ai-tools` | Maven | From 4.19.0 | 4.21.0 |
| `org.apache.camel:camel-spring-ai-tools` | Maven | From 4.8.0 | 4.18.3 |
| `org.apache.camel:camel-spring-ai-tools` | Maven | From 4.8.0 | 4.18.3 |

Products: Apache Camel.

## How do I fix CVE-2026-49042?

Upgrade org.apache.camel:camel-langchain4j-agent to a fixed version for your release line: 4.21.0 or 4.18.3.

## Is CVE-2026-49042 being exploited?

There is no known exploitation of CVE-2026-49042 in the wild and no public exploit code.

Public exploit code:

- PoC reproducer for CVE-2026-49042 (Apache Camel camel-langchain4j-tools): a prompt-injected LLM's tool-call arguments become unfiltered Exchange headers, hijacking the tool route's exec: sink for RCE. Fixed in 4.14.8/4.18.3/4.21.0. (github_poc): https://github.com/oscerd/CVE-2026-49042

## Other vulnerabilities in Apache Camel

- [CVE-2026-33453](https://insights.sbomify.com/CVE-2026-33453/): Apache camel-coap allows header injection that can lead to remote code execution (critical 10.0)
- [CVE-2026-40453](https://insights.sbomify.com/CVE-2026-40453/): Apache Camel has an incomplete fix for CVE-2025-27636 (critical 9.9)
- [CVE-2026-80351](https://insights.sbomify.com/CVE-2026-80351/): Apache Camel K: Camel K Tenant repositories reach Maven execution inside operator pod (critical 9.8)
- [CVE-2026-80352](https://insights.sbomify.com/CVE-2026-80352/): Apache Camel K: Camel K Master trait serviceAccountName YAML injection lets CR author apply arbitrary objects (critical 9.8)
- [CVE-2026-71300](https://insights.sbomify.com/CVE-2026-71300/): Apache Camel: Camel-Atmosphere-Websocket: WebSocket dispatch header injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49042 and fix it if it is affected.

What it is: CVE-2026-49042 is a high-severity vulnerability in Apache Camel, published on 6 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-49042 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.camel:camel-langchain4j-agent (Maven): affected from 4.19.0; fixed in 4.21.0
- org.apache.camel:camel-langchain4j-agent (Maven): affected from 4.19.0; fixed in 4.21.0
- org.apache.camel:camel-langchain4j-agent (Maven): affected from 4.8.0; fixed in 4.18.3
- org.apache.camel:camel-langchain4j-agent (Maven): affected from 4.8.0; fixed in 4.18.3
- org.apache.camel:camel-langchain4j-tools (Maven): affected from 4.19.0; fixed in 4.21.0
- org.apache.camel:camel-langchain4j-tools (Maven): affected from 4.19.0; fixed in 4.21.0
- org.apache.camel:camel-langchain4j-tools (Maven): affected from 4.8.0; fixed in 4.18.3
- org.apache.camel:camel-langchain4j-tools (Maven): affected from 4.8.0; fixed in 4.18.3
- org.apache.camel:camel-spring-ai-tools (Maven): affected from 4.19.0; fixed in 4.21.0
- org.apache.camel:camel-spring-ai-tools (Maven): affected from 4.19.0; fixed in 4.21.0
- org.apache.camel:camel-spring-ai-tools (Maven): affected from 4.8.0; fixed in 4.18.3
- org.apache.camel:camel-spring-ai-tools (Maven): affected from 4.8.0; fixed in 4.18.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49042/ (Markdown: https://insights.sbomify.com/CVE-2026-49042/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49042
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49042
- OSV: https://osv.dev/vulnerability/CVE-2026-49042

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49042/
Summaries are generated and may contain mistakes; the official description above is the record.
