# CVE-2026-49086: Apache Camel-Dapr: The Dapr Pub/Sub consumer copied the inbound CloudEvent's pub/sub-name and topic into producer-direction routing headers

> An attacker publishing to a subscribed topic can redirect messages to arbitrary destinations by manipulating CloudEvent headers, bypassing routing controls.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jul 2026
- **Updated:** 6 Jul 2026
- **Also known as:** GHSA-583r-f84w-33g7

## What is CVE-2026-49086?

CVE-2026-49086 is a medium-severity vulnerability in Apache Camel, published on 6 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Input Validation, Unintended Proxy or Intermediary ('Confused Deputy') vulnerability in Apache Camel DAPR component.

The camel-dapr Dapr Pub/Sub consumer (DaprPubSubConsumer) copied two fields from each inbound CloudEvent - its Pub/Sub component name and its topic - into the CamelDaprPubSubName and CamelDaprTopic Exchange headers. These two headers are producer-direction routing headers: when the route republishes through a Dapr producer, DaprConfigurationOptionsProxy reads them back and prefers them over the destination configured on the endpoint. As a result, in a route that consumes from one Dapr Pub/Sub topic and republishes to another (for example from('dapr-pubsub:p:t').to('dapr-pubsub:p:other')), an actor able to publish a message to the subscribed topic could set the CloudEvent's pub/sub-name and topic to values of their choosing and cause the re-published message to be delivered to an arbitrary Dapr Pub/Sub component and topic instead of the configured destination - redirecting or exfiltrating the message and bypassing the route's intended routing and any topic-level access controls in the underlying broker. Exploitation requires the ability to publish to the topic the route subscribes to; no other authentication or user interaction is needed.
This issue affects Apache Camel: from 4.12.0 before 4.14.8, from 4.15.0 before 4.18.3, from 4.19.0 before 4.21.0.

Users are recommended to upgrade to version 4.21.0, which fixes the issue. If users are on the 4.14.x LTS releases stream, then they are suggested to upgrade to 4.14.8. If users are on the 4.18.x releases stream, then they are suggested to upgrade to 4.18.3. For deployments that cannot upgrade immediately, remove the CamelDaprPubSubName and CamelDaprTopic headers from the Exchange between the Dapr consumer and any Dapr producer in the route (for example removeHeaders('CamelDaprPubSubName', 'CamelDaprTopic')), and restrict who can publish to the subscribed Dapr Pub/Sub topic so that only trusted producers can send to it.

Weakness: CWE-441 (Unintended Proxy or Intermediary), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-49086?

6 open source packages ship an affected version, including org.apache.camel:camel-dapr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.camel:camel-dapr` | Maven | From 4.12.0 | 4.14.8 |
| `org.apache.camel:camel-dapr` | Maven | From 4.12.0 | 4.14.8 |
| `org.apache.camel:camel-dapr` | Maven | From 4.15.0 | 4.18.3 |
| `org.apache.camel:camel-dapr` | Maven | From 4.15.0 | 4.18.3 |
| `org.apache.camel:camel-dapr` | Maven | From 4.19.0 | 4.21.0 |
| `org.apache.camel:camel-dapr` | Maven | From 4.19.0 | 4.21.0 |

Products: Apache Camel.

## How do I fix CVE-2026-49086?

Upgrade org.apache.camel:camel-dapr to a fixed version for your release line: 4.14.8, 4.18.3 or 4.21.0.

## Is CVE-2026-49086 being exploited?

There is no known exploitation of CVE-2026-49086 in the wild and no public exploit code.

Public exploit code:

- PoC reproducer for CVE-2026-49086 (Apache Camel camel-dapr): the pub/sub consumer copies the untrusted CloudEvent's pubsubName/topic into producer-routing headers, letting an attacker redirect a republished message to an arbitrary Dapr pub/sub component+topic (confused deputy). Fixed in 4.14.8/4.18.3/4.21.0. (github_poc): https://github.com/oscerd/CVE-2026-49086

## Other vulnerabilities in Apache Camel

- [CVE-2026-33453](https://insights.sbomify.com/CVE-2026-33453/): Apache camel-coap allows header injection that can lead to remote code execution (critical 10.0)
- [CVE-2026-40453](https://insights.sbomify.com/CVE-2026-40453/): Apache Camel has an incomplete fix for CVE-2025-27636 (critical 9.9)
- [CVE-2026-80351](https://insights.sbomify.com/CVE-2026-80351/): Apache Camel K: Camel K Tenant repositories reach Maven execution inside operator pod (critical 9.8)
- [CVE-2026-80352](https://insights.sbomify.com/CVE-2026-80352/): Apache Camel K: Camel K Master trait serviceAccountName YAML injection lets CR author apply arbitrary objects (critical 9.8)
- [CVE-2026-71300](https://insights.sbomify.com/CVE-2026-71300/): Apache Camel: Camel-Atmosphere-Websocket: WebSocket dispatch header injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49086 and fix it if it is affected.

What it is: CVE-2026-49086 is a medium-severity vulnerability in Apache Camel, published on 6 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-49086 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.camel:camel-dapr (Maven): affected from 4.12.0; fixed in 4.14.8
- org.apache.camel:camel-dapr (Maven): affected from 4.12.0; fixed in 4.14.8
- org.apache.camel:camel-dapr (Maven): affected from 4.15.0; fixed in 4.18.3
- org.apache.camel:camel-dapr (Maven): affected from 4.15.0; fixed in 4.18.3
- org.apache.camel:camel-dapr (Maven): affected from 4.19.0; fixed in 4.21.0
- org.apache.camel:camel-dapr (Maven): affected from 4.19.0; fixed in 4.21.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49086/ (Markdown: https://insights.sbomify.com/CVE-2026-49086/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49086
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49086
- OSV: https://osv.dev/vulnerability/CVE-2026-49086

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49086/
Summaries are generated and may contain mistakes; the official description above is the record.
