# CVE-2026-49092: Unintended Proxy or Intermediary ('Confused Deputy') in Kibana Leading to Unauthorized Information Exposure

> A confused deputy flaw in Kibana allows lower-privileged users to access unauthorized data by leveraging another user's privileges.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jul 2026
- **Updated:** 22 Jul 2026
- **Also known as:** BIT-elk-2026-49092, BIT-kibana-2026-49092, GHSA-2529-45pr-jcrg, MINI-xfpm-g6g8-9245

## What is CVE-2026-49092?

CVE-2026-49092 is a medium-severity missing authorization vulnerability in Elastic Kibana, published on 21 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Unintended Proxy or Intermediary ('Confused Deputy') (CWE-441) in Kibana can lead to unauthorized information exposure via Accessing Functionality Not Properly Constrained by ACLs (CAPEC-1). Under certain conditions, a lower-privileged user can cause data from sources they are not authorized to access to be processed using another user's privileges.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-49092?

2 open source packages ship an affected version, including kibana and elk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kibana` | Bitnami | From 9.4.0 | 9.4.3 |
| `elk` | Bitnami | From 9.4.0 | 9.4.3 |

Products: Elastic Kibana.

## How do I fix CVE-2026-49092?

Upgrade kibana to 9.4.3 or later.

## Is CVE-2026-49092 being exploited?

There is no known exploitation of CVE-2026-49092 in the wild and no public exploit code.

## Other vulnerabilities in Elastic Kibana

- [CVE-2019-7609](https://insights.sbomify.com/CVE-2019-7609/): Kibana Arbitrary Code Execution (critical 9.8, exploited in the wild)
- [CVE-2025-25015](https://insights.sbomify.com/CVE-2025-25015/): Kibana arbitrary code execution via prototype pollution (critical 9.9)
- [CVE-2024-37288](https://insights.sbomify.com/CVE-2024-37288/): Deserialization in Kibana (critical 9.9)
- [CVE-2023-31415](https://insights.sbomify.com/CVE-2023-31415/): Code injection in Kibana (critical 9.9)
- [CVE-2018-17245](https://insights.sbomify.com/CVE-2018-17245/): Information disclosure in Kibana (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49092 and fix it if it is affected.

What it is: CVE-2026-49092 is a medium-severity missing authorization vulnerability in Elastic Kibana, published on 21 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-49092 in the wild and no public exploit code.

Affected packages and fixed versions:
- kibana (Bitnami): affected from 9.4.0; fixed in 9.4.3
- elk (Bitnami): affected from 9.4.0; fixed in 9.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49092/ (Markdown: https://insights.sbomify.com/CVE-2026-49092/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49092
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49092
- OSV: https://osv.dev/vulnerability/CVE-2026-49092

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49092/
Summaries are generated and may contain mistakes; the official description above is the record.
