# CVE-2026-49094: Uncontrolled Resource Consumption in Kibana Leading to Denial of Service

> An authenticated viewer can cause Kibana denial of service by submitting oversized input to an analytics endpoint, exhausting system resources.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 May 2026
- **Updated:** 29 May 2026
- **Also known as:** BIT-elk-2026-49094, BIT-kibana-2026-49094, GHSA-q4c9-4pm6-jq34, MINI-6vpv-rm6g-95f3, MINI-vxp9-5prv-7gqw

## What is CVE-2026-49094?

CVE-2026-49094 is a medium-severity denial of service vulnerability in Elastic Kibana, published on 28 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Uncontrolled Resource Consumption (CWE-400) in Kibana can lead to denial of service via Excessive Allocation (CAPEC-130). An authenticated user with viewer-level access can submit a request containing an oversized input value to an analytics collections management endpoint. Kibana will consume excessive CPU and memory resources while processing the request. This results in Kibana becoming unavailable to all users until the service is manually recovered.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-49094?

2 open source packages ship an affected version, including kibana and elk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kibana` | Bitnami | From 8.0.0 | 8.19.16 |
| `elk` | Bitnami | From 8.0.0 | 8.19.16 |

Products: Elastic Kibana.

## How do I fix CVE-2026-49094?

Upgrade kibana to 8.19.16 or later.

## Is CVE-2026-49094 being exploited?

There is no known exploitation of CVE-2026-49094 in the wild and no public exploit code.

## Other vulnerabilities in Elastic Kibana

- [CVE-2019-7609](https://insights.sbomify.com/CVE-2019-7609/): Kibana Arbitrary Code Execution (critical 9.8, exploited in the wild)
- [CVE-2025-25015](https://insights.sbomify.com/CVE-2025-25015/): Kibana arbitrary code execution via prototype pollution (critical 9.9)
- [CVE-2024-37288](https://insights.sbomify.com/CVE-2024-37288/): Deserialization in Kibana (critical 9.9)
- [CVE-2023-31415](https://insights.sbomify.com/CVE-2023-31415/): Code injection in Kibana (critical 9.9)
- [CVE-2018-17245](https://insights.sbomify.com/CVE-2018-17245/): Information disclosure in Kibana (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49094 and fix it if it is affected.

What it is: CVE-2026-49094 is a medium-severity denial of service vulnerability in Elastic Kibana, published on 28 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-49094 in the wild and no public exploit code.

Affected packages and fixed versions:
- kibana (Bitnami): affected from 8.0.0; fixed in 8.19.16
- elk (Bitnami): affected from 8.0.0; fixed in 8.19.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49094/ (Markdown: https://insights.sbomify.com/CVE-2026-49094/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49094
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49094
- OSV: https://osv.dev/vulnerability/CVE-2026-49094

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49094/
Summaries are generated and may contain mistakes; the official description above is the record.
