# CVE-2026-49097: Apache Camel-IRC: The irc.sendTo (and other irc.*) Exchange header constants used non-Camel-prefixed names that bypass the HTTP header filter

> Attackers can redirect IRC messages to arbitrary destinations by injecting unfiltered HTTP headers in Apache Camel routes bridging HTTP to IRC.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jul 2026
- **Updated:** 6 Jul 2026
- **Also known as:** GHSA-463m-2hr2-q2j7

## What is CVE-2026-49097?

CVE-2026-49097 is a medium-severity vulnerability in Apache Camel, published on 6 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Input Validation, Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection') vulnerability in Apache Camel IRC component.

The camel-irc producer chooses the destination of an outgoing IRC message from the irc.sendTo Exchange header (the constant IrcConstants.IRC_SEND_TO, value irc.sendTo); when that header is present it overrides the channel list configured on the endpoint, and the message is sent only to the specified destination. This and the component's other control headers (irc.target, irc.messageType, irc.user.*, irc.num, irc.value) used plain, non-Camel-prefixed values. Because these names do not start with the Camel / camel prefix, HttpHeaderFilterStrategy - which blocks only the Camel header namespace on the HTTP boundary - let them pass from an inbound HTTP request straight into the Exchange. In a route that bridges an HTTP consumer (for example platform-http) into an irc: producer, any HTTP client could therefore set the irc.sendTo header and redirect a message that the route intended for a configured channel to an arbitrary IRC channel or user - exfiltrating the message content to an attacker-chosen nickname, leaking it into a public channel, or delivering messages that appear to come from the bot. No credentials are required when the bridging consumer is unauthenticated.
This issue affects Apache Camel: from 4.0.0 before 4.14.8, from 4.15.0 before 4.18.3, from 4.19.0 before 4.21.0.

Users are recommended to upgrade to version 4.21.0, which fixes the issue. If users are on the 4.14.x LTS releases stream, then they are suggested to upgrade to 4.14.8. If users are on the 4.18.x releases stream, then they are suggested to upgrade to 4.18.3. After upgrading, routes that set IRC headers via the raw header names must use the CamelIrc* names (for example CamelIrcSendTo) instead of the old irc.* values. For deployments that cannot upgrade immediately, strip the irc.* headers from any untrusted ingress before the irc: producer (for example removeHeaders('irc.*') at the start of the route), and set the IRC destination from a trusted source.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-49097?

6 open source packages ship an affected version, including org.apache.camel:camel-irc. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.camel:camel-irc` | Maven | From 4.0.0 | 4.14.8 |
| `org.apache.camel:camel-irc` | Maven | From 4.0.0 | 4.14.8 |
| `org.apache.camel:camel-irc` | Maven | From 4.15.0 | 4.18.3 |
| `org.apache.camel:camel-irc` | Maven | From 4.15.0 | 4.18.3 |
| `org.apache.camel:camel-irc` | Maven | From 4.19.0 | 4.21.0 |
| `org.apache.camel:camel-irc` | Maven | From 4.19.0 | 4.21.0 |

Products: Apache Camel.

## How do I fix CVE-2026-49097?

Upgrade org.apache.camel:camel-irc to a fixed version for your release line: 4.14.8, 4.18.3 or 4.21.0.

## Is CVE-2026-49097 being exploited?

There is no known exploitation of CVE-2026-49097 in the wild and no public exploit code.

Public exploit code:

- PoC reproducer for CVE-2026-49097 (Apache Camel camel-irc): the non-Camel-prefixed irc.sendTo header escapes the HTTP header filter and overrides the producer's configured channel, redirecting an IRC message to an attacker-chosen destination. Fixed in 4.14.8/4.18.3/4.21.0. (github_poc): https://github.com/oscerd/CVE-2026-49097

## Other vulnerabilities in Apache Camel

- [CVE-2026-33453](https://insights.sbomify.com/CVE-2026-33453/): Apache camel-coap allows header injection that can lead to remote code execution (critical 10.0)
- [CVE-2026-40453](https://insights.sbomify.com/CVE-2026-40453/): Apache Camel has an incomplete fix for CVE-2025-27636 (critical 9.9)
- [CVE-2026-80351](https://insights.sbomify.com/CVE-2026-80351/): Apache Camel K: Camel K Tenant repositories reach Maven execution inside operator pod (critical 9.8)
- [CVE-2026-80352](https://insights.sbomify.com/CVE-2026-80352/): Apache Camel K: Camel K Master trait serviceAccountName YAML injection lets CR author apply arbitrary objects (critical 9.8)
- [CVE-2026-71300](https://insights.sbomify.com/CVE-2026-71300/): Apache Camel: Camel-Atmosphere-Websocket: WebSocket dispatch header injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49097 and fix it if it is affected.

What it is: CVE-2026-49097 is a medium-severity vulnerability in Apache Camel, published on 6 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-49097 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.camel:camel-irc (Maven): affected from 4.0.0; fixed in 4.14.8
- org.apache.camel:camel-irc (Maven): affected from 4.0.0; fixed in 4.14.8
- org.apache.camel:camel-irc (Maven): affected from 4.15.0; fixed in 4.18.3
- org.apache.camel:camel-irc (Maven): affected from 4.15.0; fixed in 4.18.3
- org.apache.camel:camel-irc (Maven): affected from 4.19.0; fixed in 4.21.0
- org.apache.camel:camel-irc (Maven): affected from 4.19.0; fixed in 4.21.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49097/ (Markdown: https://insights.sbomify.com/CVE-2026-49097/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49097
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49097
- OSV: https://osv.dev/vulnerability/CVE-2026-49097

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49097/
Summaries are generated and may contain mistakes; the official description above is the record.
