CVE-2026-49099 Apache Camel-Salesforce: Non-Camel-prefixed Exchange header constants bypass the HTTP header filter
Attackers can inject HTTP headers to override Salesforce operation parameters, allowing unauthorized data access or modification via the integration user's permissions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-49099?
CVE-2026-49099 is a medium-severity missing authorization vulnerability in Apache Camel, published on 6 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection'), Authorization Bypass Through User-Controlled Key vulnerability in Apache Camel Salesforce Component.
The camel-salesforce producer resolves its operation parameters - the SOQL query, the SOSL search, the target SObject name and id, the Apex REST URL and method, and the Apex query parameters - from Exchange message headers, reading the header in preference to the value configured on the endpoint (AbstractSalesforceProcessor.getParameter() reads the header first and uses the endpoint configuration only as a fallback). The control-header constants in SalesforceEndpointConfig (for example SOBJECT_QUERY = sObjectQuery, SOBJECT_SEARCH = sObjectSearch, SOBJECT_NAME = sObjectName, SOBJECT_ID = sObjectId, APEX_URL = apexUrl, APEX_METHOD = apexMethod, and the apexQueryParam. prefix) used plain, non-Camel-prefixed values. Because these names do not start with the Camel / camel prefix, HttpHeaderFilterStrategy - which blocks only the Camel header namespace on the HTTP boundary - let them pass from an inbound HTTP request straight into the Exchange. In a route that bridges an HTTP consumer (for example platform-http) into a salesforce: producer, any HTTP client could therefore set these headers and override what the route intended - supplying its own SOQL query or SOSL search to read data from any SObject the connected Salesforce user can access, overriding the target SObject name and id for CRUD operations, or redirecting an Apex REST call to a different endpoint and HTTP method (including destructive methods) with injected query parameters. All such operations run with the full permissions of the Salesforce connected (integration) user, which is typically broad. No credentials are required from the attacker when the bridging consumer is unauthenticated. This issue affects Apache Camel: from 4.0.0 before 4.14.8, from 4.15.0 before 4.18.3, from 4.19.0 before 4.21.0.
Users are recommended to upgrade to version 4.21.0, which fixes the issue. If users are on the 4.14.x LTS releases stream, then they are suggested to upgrade to 4.14.8. If users are on the 4.18.x releases stream, then they are suggested to upgrade to 4.18.3. After upgrading, routes that set Salesforce operation parameters via the raw header names must use the CamelSalesforce* names (for example CamelSalesforceSObjectQuery and CamelSalesforceApexUrl) instead of the old sObject* / apex* values; the endpoint-option spelling is unchanged. For deployments that cannot upgrade immediately, strip the Salesforce control headers from any untrusted ingress before the salesforce: producer (for example removeHeaders('sObject*') and removeHeaders('apex*') at the start of the route), and set the query, SObject and Apex parameters from a trusted source.
Which versions are affected by CVE-2026-49099?
6 open source packages ship an affected version, including org.apache.camel:camel-salesforce. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.camel:camel-salesforce Maven | From 4.0.0 | 4.14.8 |
org.apache.camel:camel-salesforce Maven | From 4.0.0 | 4.14.8 |
org.apache.camel:camel-salesforce Maven | From 4.15.0 | 4.18.3 |
org.apache.camel:camel-salesforce Maven | From 4.15.0 | 4.18.3 |
org.apache.camel:camel-salesforce Maven | From 4.19.0 | 4.21.0 |
org.apache.camel:camel-salesforce Maven | From 4.19.0 | 4.21.0 |
Products include Apache Camel.
How do I fix CVE-2026-49099?
Upgrade org.apache.camel:camel-salesforce to a fixed version for your release line: 4.14.8, 4.18.3 or 4.21.0.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-49099 being exploited?
There is no known exploitation of CVE-2026-49099 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Apache Camel
- CVE-2026-33453 Apache camel-coap allows header injection that can lead to remote code execution
- CVE-2026-40453 Apache Camel has an incomplete fix for CVE-2025-27636
- CVE-2026-80351 Apache Camel K: Camel K Tenant repositories reach Maven execution inside operator pod
- CVE-2026-80352 Apache Camel K: Camel K Master trait serviceAccountName YAML injection lets CR author apply arbitrary objects
- CVE-2026-71300 Apache Camel: Camel-Atmosphere-Websocket: WebSocket dispatch header injection
Sources
Also known as CLEANSTART-2026-CV55977, CLEANSTART-2026-VC78529, GHSA-gcc7-c8mp-34qx, MINI-782h-5vp8-mg8h.