# CVE-2026-49114: ONNX symlink-following and path-traversal arbitrary file write

> A local attacker can exploit symlink following in ONNX to write arbitrary data to sensitive files, potentially leading to privilege escalation or code execution.

- **Severity:** Medium 6.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Aug 2026
- **Updated:** 21 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-49114, ECHO-9c6f-74fc-9d53, GHSA-q56x-g2fj-4rj6, PYSEC-2026-3876, UBUNTU-CVE-2026-49114

## What is CVE-2026-49114?

CVE-2026-49114 is a medium-severity path traversal vulnerability in ONNX, published on 21 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

In ONNX before 1.21.0, the 'save_external_data' function builds the external-data file path from the model's external_data location field and opens it for writing without 'O_NOFOLLOW/O_EXCL', after a non-atomic 'os.path.isfile()' check. A local attacker with write access to the directory where a victim serializes external data can deterministically pre-plant a symlink that is being followed, causing the victim's write to append to any file the victim can write, e.g. ~/.ssh/authorized_keys, cron files, or application configs. Fixed in 1.21.0.

Weakness: CWE-59 (Improper Link Resolution Before File Access), CWE-367 (Time-of-check Time-of-use (TOCTOU) Race Condition), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-49114?

3 open source packages ship an affected version, including onnx. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `onnx` | PyPI | All versions | 1.21.0 |
| `onnx` | PyPI | All versions | 1.21.0 |
| `onnx` | PyPI | All versions | 1.21.0 |

Products: Linuxfoundation Onnx.

## How do I fix CVE-2026-49114?

Upgrade onnx to 1.21.0 or later.

## Is CVE-2026-49114 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49114 exists.

## Other vulnerabilities in ONNX

- [CVE-2025-51480](https://insights.sbomify.com/CVE-2025-51480/): Path traversal in n/a (high 8.8)
- [CVE-2024-5187](https://insights.sbomify.com/CVE-2024-5187/): Arbitrary File Overwrite in download_model_with_test_data in onnx/onnx (high 8.8)
- [CVE-2026-27489](https://insights.sbomify.com/CVE-2026-27489/): ONNX: Path Traversal via Symlink (high 8.7)
- [CVE-2026-34445](https://insights.sbomify.com/CVE-2026-34445/): ONNX: Malicious ONNX models can crash servers by exploiting unprotected object settings. (high 8.6)
- [CVE-2026-28500](https://insights.sbomify.com/CVE-2026-28500/): ONNX Untrusted Model Repository Warnings Suppressed by silent=True in onnx.hub.load() — Silent Supply-Chain Attack (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49114 and fix it if it is affected.

What it is: CVE-2026-49114 is a medium-severity path traversal vulnerability in ONNX, published on 21 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49114 exists.

Affected packages and fixed versions:
- onnx (PyPI): affected all versions; fixed in 1.21.0
- onnx (PyPI): affected all versions; fixed in 1.21.0
- onnx (PyPI): affected all versions; fixed in 1.21.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49114/ (Markdown: https://insights.sbomify.com/CVE-2026-49114/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49114
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49114
- OSV: https://osv.dev/vulnerability/CVE-2026-49114

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49114/
Summaries are generated and may contain mistakes; the official description above is the record.
