# CVE-2026-49138: Nanobot < 0.2.1 SSRF via web_fetch Tool Redirect Following

> Remote attackers can exploit redirect handling in the web_fetch tool to access internal network hosts, requiring an upgrade to Nanobot.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:L/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jun 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-434r-7c99-hwf3, PYSEC-2026-3580

## What is CVE-2026-49138?

CVE-2026-49138 is a medium-severity server-side request forgery vulnerability in HKUDS nanobot, published on 1 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Nanobot prior to version 0.2.1 contains a server-side request forgery vulnerability in the web_fetch tool that allows remote attackers to reach internal or private network hosts by supplying a URL that redirects to a loopback or private address via a 3xx Location header. Attackers can exploit the automatic HTTP redirect following behavior in the httpx library to bypass initial URL validation and cause the runtime to send outbound requests to internal hosts before final resolved URL validation is applied.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-49138?

3 open source packages ship an affected version, including nanobot-ai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nanobot-ai` | PyPI | All versions | 0.2.1 |
| `nanobot-ai` | PyPI | All versions | 0.2.1 |
| `nanobot-ai` | PyPI | All versions | 0.2.1 |

## How do I fix CVE-2026-49138?

Upgrade nanobot-ai to 0.2.1 or later.

## Is CVE-2026-49138 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49138 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49138 and fix it if it is affected.

What it is: CVE-2026-49138 is a medium-severity server-side request forgery vulnerability in HKUDS nanobot, published on 1 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49138 exists.

Affected packages and fixed versions:
- nanobot-ai (PyPI): affected all versions; fixed in 0.2.1
- nanobot-ai (PyPI): affected all versions; fixed in 0.2.1
- nanobot-ai (PyPI): affected all versions; fixed in 0.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49138/ (Markdown: https://insights.sbomify.com/CVE-2026-49138/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49138
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49138
- OSV: https://osv.dev/vulnerability/CVE-2026-49138

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49138/
Summaries are generated and may contain mistakes; the official description above is the record.
