CVE-2026-4915 Server panic via outgoing webhook responses

Medium 6.5 Published Updated

An authenticated user can crash the Mattermost server by sending a crafted webhook response with null attachment entries.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-4915?

CVE-2026-4915 is a medium-severity denial of service vulnerability in Mattermost Mattermost Server, published on 25 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Mattermost versions 11.6.x <= 11.6.0, 11.5.x <= 11.5.3, 11.4.x <= 11.4.4, 10.11.x <= 10.11.14 fail to filter nil elements from outgoing webhook attachment payloads before processing, which allows an authenticated user to cause a denial of service (server process termination) via a crafted webhook callback response containing a null attachment entry.. Mattermost Advisory ID: MMSA-2026-00641

Weakness: CWE-754

Which versions are affected by CVE-2026-4915?

14 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.

PackageAffectedFixed in
github.com/mattermost/mattermost-server GoFrom 10.11.010.11.15
github.com/mattermost/mattermost-server GoFrom 10.11.010.11.15
github.com/mattermost/mattermost-server GoFrom 10.11.0+incompatible10.11.15+incompatible, 11.4.5+incompatible, 11.5.4+incompatible, 11.6.1+incompatible
github.com/mattermost/mattermost-server GoFrom 11.4.011.4.5
github.com/mattermost/mattermost-server GoFrom 11.4.011.4.5
github.com/mattermost/mattermost-server GoFrom 11.5.011.5.4
8 more packages
github.com/mattermost/mattermost-server GoFrom 11.5.011.5.4
github.com/mattermost/mattermost-server GoFrom 11.6.011.6.1
github.com/mattermost/mattermost-server GoFrom 11.6.011.6.1
github.com/mattermost/mattermost-server/v5 GoAll versionsNone
github.com/mattermost/mattermost-server/v6 GoAll versionsNone
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20260407102538-faa7d75b4ea0
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20260407102538-faa7d75b4ea0
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20260407102538-faa7d75b4ea0

Products include Mattermost Mattermost Server.

How do I fix CVE-2026-4915?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.11.15, 10.11.15+incompatible, 11.4.5+incompatible or 11.5.4+incompatible.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-4915 being exploited?

There is no known exploitation of CVE-2026-4915 in the wild and no public exploit code.

All Mattermost Mattermost Server vulnerabilities

Sources

Also known as GHSA-5gmf-x7hg-97wf, GO-2026-5845.

Is CVE-2026-4915 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free