CVE-2026-49157 Apache ActiveMQ: Authenticated low-privilege Web users retain Jolokia broker-management capability by default
Low-privilege web users can execute administrative broker management operations due to incorrect default Jolokia authorization settings.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-49157?
CVE-2026-49157 is a high-severity missing authorization vulnerability in Apache Activemq, published on 1 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Incorrect Default Permissions vulnerability in Apache ActiveMQ.
This issue affects Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6.
The default Jolokia authorization settings granted non-admin (low-privilege) web-login accounts access to Jolokia operations which allowed executing broker management operations meant for admins such as addQueue and removeQueue.
Users are recommended to upgrade to version 6.2.6 or 5.19.7, which fixes the issue.
Weakness: CWE-276
Which versions are affected by CVE-2026-49157?
5 open source packages ship an affected version, including org.apache.activemq:apache-activemq and activemq. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.activemq:apache-activemq Maven | All versions | 5.19.7 |
org.apache.activemq:apache-activemq Maven | All versions | 5.19.7 |
org.apache.activemq:apache-activemq Maven | From 6.0.0 | 6.2.6 |
org.apache.activemq:apache-activemq Maven | From 6.0.0 | 6.2.6 |
activemq Bitnami | All versions | 5.19.7, 6.2.6 |
Products include Apache Activemq.
How do I fix CVE-2026-49157?
Upgrade org.apache.activemq:apache-activemq to a fixed version for your release line: 5.19.7 or 6.2.6.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-49157 being exploited?
There is no known exploitation of CVE-2026-49157 in the wild and no public exploit code.
Other vulnerabilities in Apache Activemq
Sources
Also known as BIT-activemq-2026-49157, DEBIAN-CVE-2026-49157, GHSA-99qx-5qqr-4j95, MINI-crw9-qj92-x6v8, MINI-gqr4-g63j-j5g7, MINI-q4f7-3qhw-4v4x and 2 more.