CVE-2026-4916 Missing Authorization in GitLab

Low 2.7 Published Updated

Authenticated users with custom roles can improperly demote or remove higher-privileged group members due to missing authorization checks.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-4916?

CVE-2026-4916 is a low-severity missing authorization vulnerability in Gitlab Gitlab, published on 8 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.2 before 18.8.9, 18.9 before 18.9.5, and 18.10 before 18.10.3 that could have allowed an authenticated user with custom role permissions to demote or remove higher-privileged group members due to improper authorization checks on member management operations.

Weakness: CWE-862

Which versions are affected by CVE-2026-4916?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 18.2.018.8.9, 18.9.5, 18.10.3

Products include Gitlab Gitlab.

How do I fix CVE-2026-4916?

Upgrade gitlab to a fixed version for your release line: 18.8.9, 18.9.5 or 18.10.3.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-4916 being exploited?

There is no known exploitation of CVE-2026-4916 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2026-4916, GHSA-h92q-g5vv-9g2c, UBUNTU-CVE-2026-4916.

Is CVE-2026-4916 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free