{"answers":{"affected":"4 open source packages ship an affected version, including thorsten/phpmyfaq and phpmyfaq/phpmyfaq.","exploited":"There is no known exploitation of CVE-2026-49205 in the wild and no public exploit code.","fix":"Upgrade thorsten/phpmyfaq to 4.1.4 or later.","what":"CVE-2026-49205 is a medium-severity missing authorization vulnerability in thorsten phpMyFAQ, published on 18 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-49205 and fix it if it is affected.\n\nWhat it is: CVE-2026-49205 is a medium-severity missing authorization vulnerability in thorsten phpMyFAQ, published on 18 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-49205 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.1.4\n- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.1.4\n- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.1.4\n- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.1.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-49205/ (Markdown: https://insights.sbomify.com/CVE-2026-49205/index.md)","id":"CVE-2026-49205","markdown":"https://insights.sbomify.com/CVE-2026-49205/index.md","name":"CVE-2026-49205","record":{"aliases":["GHSA-8c6h-7g6x-m5x4"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"phpMyFAQ","requires_auth":"low_privilege","summary":"Attackers with valid API tokens can create or modify categories, FAQs, and questions without proper user permission checks.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"phpMyFAQ is an open source FAQ web application. Versions prior to  4.1.4 have Missing Authorization in the API CategoryController. CVE-2026-24421 addressed this in the BackupController by adding: $this-\u003euserHasPermission(PermissionType::BACKUP). The same fix was not applied to 4 other write endpoints in the public API. All 4 only call $this-\u003ehasValidToken() — which checks a shared API key header, rather than the individual user's role permissions. The following APIs are affected: POST /api/v4.0/category (CategoryController::create), POST /api/v4.0/faq (FaqController::create), PUT /api/v4.0/faq (FaqController::update), and POST /api/v4.0/question (QuestionController::create). This issue has been fixed in version 4.1.4.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"phpMyFAQ: Missing userHasPermission() in 4 API write endpoints (CVE-2026-24421 Incomplete Fix)","id":"CVE-2026-49205","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":4,"n_references":2,"next":{"headline":"rapidcsv: Integer overflow in iterator arithmetic causes out-of-bounds access","id":"CVE-2026-49206"},"packages":[{"ecosystem":"Packagist","fixed":["4.1.4"],"introduced":["0"],"last_affected":[],"package":"phpmyfaq/phpmyfaq","purl":null,"source":"GHSA-8c6h-7g6x-m5x4"},{"ecosystem":"Packagist","fixed":["4.1.4"],"introduced":["0"],"last_affected":[],"package":"phpmyfaq/phpmyfaq","purl":"pkg:composer/phpmyfaq/phpmyfaq","source":"GHSA-8c6h-7g6x-m5x4"},{"ecosystem":"Packagist","fixed":["4.1.4"],"introduced":["0"],"last_affected":[],"package":"thorsten/phpmyfaq","purl":null,"source":"GHSA-8c6h-7g6x-m5x4"},{"ecosystem":"Packagist","fixed":["4.1.4"],"introduced":["0"],"last_affected":[],"package":"thorsten/phpmyfaq","purl":"pkg:composer/thorsten/phpmyfaq","source":"GHSA-8c6h-7g6x-m5x4"}],"prev":{"headline":"Hard-coded AWS Cognito Testing Accounts","id":"CVE-2026-49204"},"products":["phpMyFAQ"],"published":"2026-06-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-22","vendors":["thorsten"]},"summary":"Attackers with valid API tokens can create or modify categories, FAQs, and questions without proper user permission checks.","url":"https://insights.sbomify.com/CVE-2026-49205/"}