# CVE-2026-49214: guzzlehttp/psr7 has CRLF Injection via URI Host Component

> Attackers can inject headers via CRLF in URI hosts, enabling request smuggling or cache poisoning in applications using guzzlehttp/psr7.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jun 2026
- **Updated:** 11 Jun 2026
- **Also known as:** DEBIAN-CVE-2026-49214, GHSA-hq7v-mx3g-29hw, MINI-424x-vr43-gvh4, MINI-53pq-9qjr-j72w, MINI-57q4-hv64-56x6, MINI-g63v-2842-42cf, MINI-j2jx-66j5-mx4m, MINI-pv3c-8472-v5xw, MINI-w7mr-mjch-gr54, UBUNTU-CVE-2026-49214

## What is CVE-2026-49214?

CVE-2026-49214 is a medium-severity vulnerability in guzzle psr7, published on 11 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

guzzlehttp/psr7 is a PSR-7 HTTP message library implementation in PHP. Versions prior to 2.10.2 did not reject ASCII control characters, whitespace, or DEL in first-party URI host components. A vulnerable flow is: First, an application accepts a user-controlled URL. Second, the URL is used to construct a PSR-7 `Uri` or `Request`. Third, the host component contains CRLF or another header-unsafe character. Fourth, the host is copied into the PSR-7 `Host` header when no explicit `Host` header is provided. Finally, the request is serialized or sent by an HTTP client that does not independently reject the malformed host. In that flow, an attacker can cause the serialized request to contain additional attacker-controlled header lines. For example, a host containing `"\r\nX-Injected: yes"` can cause the generated `Host` header to span multiple HTTP header lines. Applications are affected when they use user-controlled URLs for outbound HTTP requests, URL forwarding, proxying, crawling, webhook delivery, or similar request-dispatch flows. In deployments involving HTTP/1.1 connection reuse, proxies, gateways, or load balancers, this malformed request may also contribute to request smuggling or cache poisoning, depending on how downstream components parse the request. The issue is patched in `2.10.2` and later. `1.x` is end-of-life and will not receive a patch. As a workaround, validate and reject all untrusted URI strings before constructing PSR-7 `Uri` or `Request` instances. Reject input containing ASCII control characters, whitespace, or DEL, including CRLF, tab, space, NUL, or DEL characters. Applications that forward requests should also ensure the final HTTP client or serializer rejects invalid URI and header data before writing requests to the network.

Weakness: CWE-93 (Improper Neutralization of CRLF Sequences), CWE-20 (Improper Input Validation), CWE-113 (Improper Neutralization of CRLF Sequences in HTTP Headers)

## Which versions are affected by CVE-2026-49214?

2 open source packages ship an affected version, including guzzlehttp/psr7. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `guzzlehttp/psr7` | Packagist | All versions | 2.10.2 |
| `guzzlehttp/psr7` | Packagist | All versions | 2.10.2 |

Products: Guzzlephp Psr-7.

## How do I fix CVE-2026-49214?

Upgrade guzzlehttp/psr7 to 2.10.2 or later.

## Is CVE-2026-49214 being exploited?

There is no known exploitation of CVE-2026-49214 in the wild and no public exploit code.

## Other vulnerabilities in guzzle psr7

- [CVE-2026-48998](https://insights.sbomify.com/CVE-2026-48998/): guzzlehttp/psr7 has Host Confusion via Authority Reinterpretation (medium 5.3)
- [CVE-2026-55766](https://insights.sbomify.com/CVE-2026-55766/): guzzlehttp/psr7: CRLF Injection in HTTP Start-Line Serialization (medium 4.8)
- [CVE-2026-59882](https://insights.sbomify.com/CVE-2026-59882/): guzzlehttp/psr7: Host Confusion via Weak URI Host Validation (medium 4.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49214 and fix it if it is affected.

What it is: CVE-2026-49214 is a medium-severity vulnerability in guzzle psr7, published on 11 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-49214 in the wild and no public exploit code.

Affected packages and fixed versions:
- guzzlehttp/psr7 (Packagist): affected all versions; fixed in 2.10.2
- guzzlehttp/psr7 (Packagist): affected all versions; fixed in 2.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49214/ (Markdown: https://insights.sbomify.com/CVE-2026-49214/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49214
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49214
- OSV: https://osv.dev/vulnerability/CVE-2026-49214

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49214/
Summaries are generated and may contain mistakes; the official description above is the record.
