# CVE-2026-49217: Mailu missing authentication on PATCH /api/v1/token/<id>, which allows unauthenticated removal of IP restrictions

> Unauthenticated attackers can remove IP restrictions from user tokens via the admin REST API, bypassing security controls.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 20 Aug 2026
- **Updated:** 25 Aug 2026
- **Also known as:** GHSA-2w8v-6xr5-g9gh

## What is CVE-2026-49217?

CVE-2026-49217 is a high-severity missing authorization vulnerability in Mailu, published on 20 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Mailu is a mail server as a set of Docker images. Prior to version 2024.06.52, a missing authorization check in the Mailu admin REST API allows any unauthenticated attacker to remove any potential IP restriction or update the comment field from any existing user token provided the REST API is enabled. Upgrade to Mailu 2024.06.52 to receive a patch or, as a workaround, turn the REST API off.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2026-49217?


## How do I fix CVE-2026-49217?

No fix has been published for CVE-2026-49217 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-49217 being exploited?

There is no known exploitation of CVE-2026-49217 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49217 and fix it if it is affected.

What it is: CVE-2026-49217 is a high-severity missing authorization vulnerability in Mailu, published on 20 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-49217 in the wild and no public exploit code.

Affected product: Mailu. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49217/ (Markdown: https://insights.sbomify.com/CVE-2026-49217/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49217
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49217
- OSV: https://osv.dev/vulnerability/CVE-2026-49217

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49217/
Summaries are generated and may contain mistakes; the official description above is the record.
