CVE-2026-49218 ImageMagick: Policy Bypass in DCM decoder could result in image with invalid dimensions
Attackers can cause application crashes by providing DCM images with invalid dimensions due to missing validation checks in ImageMagick.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-49218?
CVE-2026-49218 is a high-severity denial of service vulnerability in Imagemagick Imagemagick, published on 10 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to versions 6.9.13-48 and 7.1.2-24, a missing check in the DCM decoder could result in an image with invalid dimensions and that could cause crashes in other operation. This issue has been patched in versions 6.9.13-48 and 7.1.2-24.
Which versions are affected by CVE-2026-49218?
34 open source packages ship an affected version, including Magick.NET-Q16-AnyCPU, Magick.NET-Q16-HDRI-AnyCPU and Magick.NET-Q16-HDRI-OpenMP-arm64. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
Magick.NET-Q16-AnyCPU NuGet | All versions | 14.14.0 |
Magick.NET-Q16-AnyCPU NuGet | All versions | 14.14.0 |
Magick.NET-Q16-HDRI-AnyCPU NuGet | All versions | 14.14.0 |
Magick.NET-Q16-HDRI-AnyCPU NuGet | All versions | 14.14.0 |
Magick.NET-Q16-HDRI-OpenMP-arm64 NuGet | All versions | 14.14.0 |
Magick.NET-Q16-HDRI-OpenMP-arm64 NuGet | All versions | 14.14.0 |
28 more packages
Magick.NET-Q16-HDRI-arm64 NuGet | All versions | 14.14.0 |
Magick.NET-Q16-HDRI-arm64 NuGet | All versions | 14.14.0 |
Magick.NET-Q16-HDRI-x64 NuGet | All versions | 14.14.0 |
Magick.NET-Q16-HDRI-x64 NuGet | All versions | 14.14.0 |
Magick.NET-Q16-HDRI-x86 NuGet | All versions | 14.14.0 |
Magick.NET-Q16-HDRI-x86 NuGet | All versions | 14.14.0 |
Magick.NET-Q16-OpenMP-arm64 NuGet | All versions | 14.14.0 |
Magick.NET-Q16-OpenMP-arm64 NuGet | All versions | 14.14.0 |
Magick.NET-Q16-OpenMP-x64 NuGet | All versions | 14.14.0 |
Magick.NET-Q16-OpenMP-x64 NuGet | All versions | 14.14.0 |
Magick.NET-Q16-arm64 NuGet | All versions | 14.14.0 |
Magick.NET-Q16-arm64 NuGet | All versions | 14.14.0 |
Magick.NET-Q16-x64 NuGet | All versions | 14.14.0 |
Magick.NET-Q16-x64 NuGet | All versions | 14.14.0 |
Magick.NET-Q16-x86 NuGet | All versions | 14.14.0 |
Magick.NET-Q16-x86 NuGet | All versions | 14.14.0 |
Magick.NET-Q8-AnyCPU NuGet | All versions | 14.14.0 |
Magick.NET-Q8-AnyCPU NuGet | All versions | 14.14.0 |
Magick.NET-Q8-OpenMP-arm64 NuGet | All versions | 14.14.0 |
Magick.NET-Q8-OpenMP-arm64 NuGet | All versions | 14.14.0 |
Magick.NET-Q8-OpenMP-x64 NuGet | All versions | 14.14.0 |
Magick.NET-Q8-OpenMP-x64 NuGet | All versions | 14.14.0 |
Magick.NET-Q8-arm64 NuGet | All versions | 14.14.0 |
Magick.NET-Q8-arm64 NuGet | All versions | 14.14.0 |
Magick.NET-Q8-x64 NuGet | All versions | 14.14.0 |
Magick.NET-Q8-x64 NuGet | All versions | 14.14.0 |
Magick.NET-Q8-x86 NuGet | All versions | 14.14.0 |
Magick.NET-Q8-x86 NuGet | All versions | 14.14.0 |
Products include Imagemagick Imagemagick.
How do I fix CVE-2026-49218?
Upgrade Magick.NET-Q16-AnyCPU to 14.14.0 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-49218 being exploited?
There is no known exploitation of CVE-2026-49218 in the wild and no public exploit code.
Other vulnerabilities in Imagemagick Imagemagick
Sources
Also known as CLSA-2026-1782213368, CLSA-2026-1782213853, CLSA-2026-1782214212, DEBIAN-CVE-2026-49218, ECHO-3274-c737-0a57, GHSA-8pj9-6897-74xc and 3 more.