# CVE-2026-49222: Missing authorization in Vvveb

> A low-privileged vendor can read, edit, or delete questions on other vendors' products due to missing authorization checks in the Vvveb CMS.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 18 Aug 2026
- **Updated:** 18 Aug 2026
- **Also known as:** GHSA-cjhq-xqq3-6xv8

## What is CVE-2026-49222?

CVE-2026-49222 is a high-severity missing authorization vulnerability in givanz Vvveb, published on 18 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Vvveb is a powerful and easy to use CMS with page builder to build websites, blogs or ecommerce stores. Prior to 1.0.8.4, Vvveb backend product question operations allow a low-privileged Vendor to manage questions under another Vendor's products. The admin/sql/sqlite/product_question.sql queries accept a caller-controlled product_question_id and do not verify product_question.product_id against product.admin_id for the current admin_id. An attacker can read pending question content and moderation data, change question status, edit question content, or delete questions, manipulating product Q&A visibility and integrity. This issue is fixed in version 1.0.8.4.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-49222?


## How do I fix CVE-2026-49222?

No fix has been published for CVE-2026-49222 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-49222 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49222 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49222 and fix it if it is affected.

What it is: CVE-2026-49222 is a high-severity missing authorization vulnerability in givanz Vvveb, published on 18 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49222 exists.

Affected product: givanz Vvveb. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49222/ (Markdown: https://insights.sbomify.com/CVE-2026-49222/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49222
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49222
- OSV: https://osv.dev/vulnerability/CVE-2026-49222

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49222/
Summaries are generated and may contain mistakes; the official description above is the record.
