# CVE-2026-49228: Vvveb product authorization bypass allows Vendors to read, duplicate, or delete other Vendors' products

> Low-privileged vendors can read, duplicate, or delete other vendors' products due to missing authorization checks in the product controller.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 18 Aug 2026
- **Updated:** 18 Aug 2026
- **Also known as:** GHSA-j5jv-wvpg-gfh9

## What is CVE-2026-49228?

CVE-2026-49228 is a high-severity missing authorization vulnerability in givanz Vvveb, published on 18 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Vvveb is a powerful and easy to use CMS with page builder to build websites, blogs or ecommerce stores. Prior to 1.0.8.4, Vvveb backend product operations allow a low-privileged Vendor to access products owned by another Vendor. The admin/controller/product/products.php controller accepts a caller-controlled product_id for duplicate and delete actions, and admin/sql/sqlite/product.sql loads and mutates products without consistently applying the current admin_id when view_other_products or edit_other_products is absent. An attacker can read product details, duplicate products, or delete products and related catalog data, exposing commercial information and causing unauthorized copies, catalog pollution, data loss, or business disruption. This issue is fixed in version 1.0.8.4.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-49228?


## How do I fix CVE-2026-49228?

No fix has been published for CVE-2026-49228 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-49228 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49228 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49228 and fix it if it is affected.

What it is: CVE-2026-49228 is a high-severity missing authorization vulnerability in givanz Vvveb, published on 18 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49228 exists.

Affected product: givanz Vvveb. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49228/ (Markdown: https://insights.sbomify.com/CVE-2026-49228/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49228
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49228
- OSV: https://osv.dev/vulnerability/CVE-2026-49228

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49228/
Summaries are generated and may contain mistakes; the official description above is the record.
