{"answers":{"affected":"2 open source packages ship an affected version, including @actual-app/sync-server.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49229 exists.","fix":"Upgrade @actual-app/sync-server to 26.6.0 or later.","what":"CVE-2026-49229 is a high-severity authentication bypass vulnerability in actualbudget actual, published on 7 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-49229 and fix it if it is affected.\n\nWhat it is: CVE-2026-49229 is a high-severity authentication bypass vulnerability in actualbudget actual, published on 7 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49229 exists.\n\nAffected packages and fixed versions:\n- @actual-app/sync-server (npm): affected all versions; fixed in 26.6.0\n- @actual-app/sync-server (npm): affected all versions; fixed in 26.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-49229/ (Markdown: https://insights.sbomify.com/CVE-2026-49229/index.md)","id":"CVE-2026-49229","markdown":"https://insights.sbomify.com/CVE-2026-49229/index.md","name":"CVE-2026-49229","record":{"aliases":["GHSA-cq9c-6w48-qmfg"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Personal finance app","requires_auth":"low_privilege","summary":"Disabled OpenID users retain access via valid session tokens, bypassing account deactivation controls in Actual.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.3,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L","version":"3.1"},"cwes":[{"id":"CWE-613","name":"DEPRECATED: Insufficient Session Expiration"}],"description":"Actual is a local-first personal finance app. Prior to 26.6.0, in OpenID multi-user mode, disabling a user only blocks future OpenID login for that identity, while existing Actual session tokens for the disabled user remain valid. The shared session validation path accepts any existing token row that has not expired without checking whether the associated user is still enabled, allowing a disabled user to continue calling authenticated server endpoints. This issue is fixed in version 26.6.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Actual: Disabled OpenID users keep access through existing session tokens","id":"CVE-2026-49229","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"Apache APISIX: Authentication bypass in jwe-decrypt","id":"CVE-2026-49230"},"packages":[{"ecosystem":"npm","fixed":["26.6.0"],"introduced":["0"],"last_affected":[],"package":"@actual-app/sync-server","purl":null,"source":"GHSA-cq9c-6w48-qmfg"},{"ecosystem":"npm","fixed":["26.6.0"],"introduced":["0"],"last_affected":[],"package":"@actual-app/sync-server","purl":"pkg:npm/%40actual-app/sync-server","source":"GHSA-cq9c-6w48-qmfg"}],"prev":{"headline":"Vvveb product authorization bypass allows Vendors to read, duplicate, or delete other Vendors' products","id":"CVE-2026-49228"},"products":["actual"],"published":"2026-07-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-09","vendors":["actualbudget"]},"summary":"Disabled OpenID users retain access via valid session tokens, bypassing account deactivation controls in Actual.","url":"https://insights.sbomify.com/CVE-2026-49229/"}