# CVE-2026-49229: Actual: Disabled OpenID users keep access through existing session tokens

> Disabled OpenID users retain access via valid session tokens, bypassing account deactivation controls in Actual.

- **Severity:** High 8.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jul 2026
- **Updated:** 9 Jul 2026
- **Also known as:** GHSA-cq9c-6w48-qmfg

## What is CVE-2026-49229?

CVE-2026-49229 is a high-severity authentication bypass vulnerability in actualbudget actual, published on 7 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Actual is a local-first personal finance app. Prior to 26.6.0, in OpenID multi-user mode, disabling a user only blocks future OpenID login for that identity, while existing Actual session tokens for the disabled user remain valid. The shared session validation path accepts any existing token row that has not expired without checking whether the associated user is still enabled, allowing a disabled user to continue calling authenticated server endpoints. This issue is fixed in version 26.6.0.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2026-49229?

2 open source packages ship an affected version, including @actual-app/sync-server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@actual-app/sync-server` | npm | All versions | 26.6.0 |
| `@actual-app/sync-server` | npm | All versions | 26.6.0 |

## How do I fix CVE-2026-49229?

Upgrade @actual-app/sync-server to 26.6.0 or later.

## Is CVE-2026-49229 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49229 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49229 and fix it if it is affected.

What it is: CVE-2026-49229 is a high-severity authentication bypass vulnerability in actualbudget actual, published on 7 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49229 exists.

Affected packages and fixed versions:
- @actual-app/sync-server (npm): affected all versions; fixed in 26.6.0
- @actual-app/sync-server (npm): affected all versions; fixed in 26.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49229/ (Markdown: https://insights.sbomify.com/CVE-2026-49229/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49229
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49229
- OSV: https://osv.dev/vulnerability/CVE-2026-49229

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49229/
Summaries are generated and may contain mistakes; the official description above is the record.
