CVE-2026-49230 Apache APISIX: Authentication bypass in jwe-decrypt

Medium 6.3 Published Updated

Attackers can bypass authentication in Apache APISIX via the jwe-decrypt plugin, allowing unauthorized access to protected resources.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-49230?

CVE-2026-49230 is a medium-severity authentication bypass vulnerability in Apache APISIX, published on 19 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Improper Validation of Integrity Check Value vulnerability in Apache APISIX.

The jwe-decrypt plugin under default configuration is vulnerable to authentication bypass.  This issue affects Apache APISIX: from 3.8.0 through 3.16.0.

Users are recommended to upgrade to version 3.17.0, which fixes the issue.

Weakness: CWE-354

Which versions are affected by CVE-2026-49230?

1 open source package ship an affected version, including apisix. It affects 1 product.

PackageAffectedFixed in
apisix BitnamiFrom 3.8.03.17.0

Products include Apache Apisix.

How do I fix CVE-2026-49230?

Upgrade apisix to 3.17.0 or later.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2026-49230 being exploited?

There is no known exploitation of CVE-2026-49230 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

Sources

Also known as BIT-apisix-2026-49230, GHSA-3mg6-56vq-7899, MINI-m22v-5j36-hxpp.

Is CVE-2026-49230 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free