CVE-2026-49231 Apache APISIX: Identity spoofing issue in APISIX opa plugin

Low 2.3 Published Updated

Attackers can spoof identity headers to gain higher privileges on upstream services when the OPA plugin is configured non-defaultly.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-49231?

CVE-2026-49231 is a low-severity authentication bypass vulnerability in Apache APISIX, published on 19 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Authentication Bypass by Spoofing vulnerability in opa plugin.

An attacker could relay spoofed identity headers to upstream capitalising on non-default configuration in opa plugin.

This could allow the attacker to assume higher privileges on the upstream service. This issue affects Apache APISIX: from 3.5.0 through 3.16.0.

Users are recommended to upgrade to version 3.17.0, which fixes the issue.

Weakness: CWE-290

Which versions are affected by CVE-2026-49231?

1 open source package ship an affected version, including apisix. It affects 1 product.

PackageAffectedFixed in
apisix BitnamiFrom 3.5.03.18.0

Products include Apache Apisix.

How do I fix CVE-2026-49231?

Upgrade apisix to 3.18.0 or later.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2026-49231 being exploited?

There is no known exploitation of CVE-2026-49231 in the wild and no public exploit code.

Sources

Also known as BIT-apisix-2026-49231, GHSA-3cm7-pvjf-2x7q, MINI-jf8q-4xcf-xrvf.

Is CVE-2026-49231 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free