# CVE-2026-49243: Webmin: Reflected XSS in the Configuration module

> Attackers can execute arbitrary commands via reflected XSS in Webmin's Configuration module by tricking users into clicking malicious links.

- **Severity:** Critical 9.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 29 Sep 2026
- **Updated:** 13 Oct 2026
- **Also known as:** GHSA-hv4w-p8jq-2rp5

## What is CVE-2026-49243?

CVE-2026-49243 is a critical cross-site scripting vulnerability in webmin, published on 29 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Webmin is a web-based system administration tool for Unix-like servers. Prior to version 2.650, Webmin users who click on a malicious link to their server are vulnerable to this XSS vulnerability that could be used to execute attacker-controlled commands. This issue has been patched in version 2.650.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-49243?


## How do I fix CVE-2026-49243?

No fix has been published for CVE-2026-49243 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-49243 being exploited?

There is no known exploitation of CVE-2026-49243 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49243 and fix it if it is affected.

What it is: CVE-2026-49243 is a critical cross-site scripting vulnerability in webmin, published on 29 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-49243 in the wild and no public exploit code.

Affected product: webmin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49243/ (Markdown: https://insights.sbomify.com/CVE-2026-49243/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49243
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49243
- OSV: https://osv.dev/vulnerability/CVE-2026-49243

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49243/
Summaries are generated and may contain mistakes; the official description above is the record.
