# CVE-2026-49250: Conform: parseSubmission vulnerable to CPU exhaustion when parsing many unique form fields

> An unauthenticated attacker can cause CPU exhaustion and denial of service by submitting a form with many unique field names to applications using the Conform library.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Sep 2026
- **Updated:** 14 Sep 2026
- **Also known as:** GHSA-525m-7f82-2mf7

## What is CVE-2026-49250?

CVE-2026-49250 is a high-severity denial of service vulnerability in edmundhung conform, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Conform, a type-safe form validation library, allows the parsing of nested objects in the form of object.property. From 1.8.0 until 1.19.4, the parseSubmission future API in packages/conform-dom/formdata.ts repeatedly scans FormData or URLSearchParams entries by each unique field name. An unauthenticated attacker can submit a crafted form containing many unique names, causing excessive synchronous CPU work and denial of service in an application that passes the submission to parseSubmission. Applications should continue to enforce request parsing limits before invoking Conform. This issue is fixed in version 1.19.4.

Weakness: CWE-407 (Inefficient Algorithmic Complexity)

## Which versions are affected by CVE-2026-49250?

2 open source packages ship an affected version, including @conform-to/dom.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@conform-to/dom` | npm | From 1.8.0 | 1.19.4 |
| `@conform-to/dom` | npm | From 1.8.0 | 1.19.4 |

## How do I fix CVE-2026-49250?

Upgrade @conform-to/dom to 1.19.4 or later.

## Is CVE-2026-49250 being exploited?

There is no known exploitation of CVE-2026-49250 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49250 and fix it if it is affected.

What it is: CVE-2026-49250 is a high-severity denial of service vulnerability in edmundhung conform, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-49250 in the wild and no public exploit code.

Affected packages and fixed versions:
- @conform-to/dom (npm): affected from 1.8.0; fixed in 1.19.4
- @conform-to/dom (npm): affected from 1.8.0; fixed in 1.19.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49250/ (Markdown: https://insights.sbomify.com/CVE-2026-49250/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49250
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49250
- OSV: https://osv.dev/vulnerability/CVE-2026-49250

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49250/
Summaries are generated and may contain mistakes; the official description above is the record.
