# CVE-2026-49252: deepstream is vulnerable to prototype pollution

> An authenticated user with write permissions can exploit prototype pollution to escalate privileges within the deepstream.io server.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jun 2026
- **Updated:** 22 Jun 2026
- **Also known as:** GHSA-9v98-6g37-x9g6

## What is CVE-2026-49252?

CVE-2026-49252 is a critical vulnerability in deepstreamIO deepstream.io, published on 18 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

deepstream is a server that allows clients and backend services to sync data, send messages and make rpcs at scale. Versions prior to 10.0.5  are vulnerable to Prototype Pollution. Exploitation can lead to potential privilege escalation from any authenticated user with write permission to any record. This issue has been fixed in version 10.0.5.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2026-49252?

2 open source packages ship an affected version, including @deepstream/server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@deepstream/server` | npm | All versions | 10.0.5 |
| `@deepstream/server` | npm | All versions | 10.0.5 |

## How do I fix CVE-2026-49252?

Upgrade @deepstream/server to 10.0.5 or later.

## Is CVE-2026-49252 being exploited?

There is no known exploitation of CVE-2026-49252 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49252 and fix it if it is affected.

What it is: CVE-2026-49252 is a critical vulnerability in deepstreamIO deepstream.io, published on 18 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-49252 in the wild and no public exploit code.

Affected packages and fixed versions:
- @deepstream/server (npm): affected all versions; fixed in 10.0.5
- @deepstream/server (npm): affected all versions; fixed in 10.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49252/ (Markdown: https://insights.sbomify.com/CVE-2026-49252/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49252
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49252
- OSV: https://osv.dev/vulnerability/CVE-2026-49252

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49252/
Summaries are generated and may contain mistakes; the official description above is the record.
