# CVE-2026-49260: php-weasyprint: shell command injection via configurable WeasyPrint binary path due to inverted is_executable() guard (mirror of KnpLabs/snappy GHSA-vpr4-p6fq-85jc)

> Attackers can execute arbitrary shell commands if the WeasyPrint binary path is configurable, due to a flawed executable check.

- **Severity:** High 8.2 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jun 2026
- **Updated:** 22 Jun 2026
- **Also known as:** GHSA-f5gc-qxf8-mh9g

## What is CVE-2026-49260?

CVE-2026-49260 is a high-severity command injection vulnerability in pontedilana php-weasyprint, published on 19 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

PhpWeasyPrint is a PHP library allowing PDF generation from a URL or an HTML page. Prior to version 2.5.1, `pontedilana/php-weasyprint` builds the shell command for WeasyPrint by passing the binary path through `escapeshellarg()` first and then checking the *quoted* result with `is_executable()`. On POSIX `escapeshellarg('/usr/local/bin/weasyprint')` returns `'/usr/local/bin/weasyprint'` with the single-quote characters as part of the string, so `is_executable()` looks for a file whose actual name includes those quotes. That file never exists, the "safe" branch is dead code, and the raw `$binary` string (set via the constructor or `setBinary()`) flows directly into `Symfony\Component\Process\Process::fromShellCommandline()`. Any deployment whose binary path is sourced from configuration, an environment variable, or a per-tenant setting reaches a shell-command-injection sink. The library is documented as a one-to-one substitute for KnpLabs/snappy and inherited the exact pre-fix codepath KnpLabs patched in GHSA-vpr4-p6fq-85jc. PhpWeasyPrint version 2.5.1 contains a patch for the issue.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-49260?

2 open source packages ship an affected version, including pontedilana/php-weasyprint.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pontedilana/php-weasyprint` | Packagist | All versions | 2.5.1 |
| `pontedilana/php-weasyprint` | Packagist | All versions | 2.5.1 |

## How do I fix CVE-2026-49260?

Upgrade pontedilana/php-weasyprint to 2.5.1 or later.

## Is CVE-2026-49260 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49260 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49260 and fix it if it is affected.

What it is: CVE-2026-49260 is a high-severity command injection vulnerability in pontedilana php-weasyprint, published on 19 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49260 exists.

Affected packages and fixed versions:
- pontedilana/php-weasyprint (Packagist): affected all versions; fixed in 2.5.1
- pontedilana/php-weasyprint (Packagist): affected all versions; fixed in 2.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49260/ (Markdown: https://insights.sbomify.com/CVE-2026-49260/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49260
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49260
- OSV: https://osv.dev/vulnerability/CVE-2026-49260

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49260/
Summaries are generated and may contain mistakes; the official description above is the record.
