CVE-2026-49261 MariaDB server has unsafe parameter handling in `wsrep_notify_cmd`

Critical 10.0 Published Updated

Attackers can execute arbitrary shell commands via node names if wsrep_notify_cmd is enabled in MariaDB server.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-49261?

CVE-2026-49261 is a critical command injection vulnerability in Mariadb Mariadb, published on 11 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

MariaDB server is a community developed fork of MySQL server. Versions 10.6.1 through 10.6.26, 10.11.1 through 10.11.17, 11.4.1 through 11.4.11, 11.8.1 through 11.8.7, and 12.3.1 with `wsrep_notify_cmd` enabled would execute shell commands embedded in the name of the joiner node. This is fixed in 10.6.27, 10.11.18, 11.4.12, 11.8.8, and 12.3.2. As a workaround, anyone who cannot upgrade now should disable `wsrep_notify_cmd`.

Weakness: CWE-78

Which versions are affected by CVE-2026-49261?

3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 1 product.

PackageAffectedFixed in
mariadb BitnamiFrom 10.6.110.6.27, 10.11.18, 11.4.12, 11.8.8, 12.3.2
mariadb-min BitnamiFrom 10.6.110.6.27, 10.11.18, 11.4.12, 11.8.8, 12.3.2
mysql-client BitnamiFrom 10.6.110.6.27, 10.11.18, 11.4.12, 11.8.8, 12.3.2
Linux distribution packages (37)
galera AlmaLinux:10All versions26.4.27-1.el10_2
mariadb AlmaLinux:10All versions3:10.11.18-1.el10_2.alma.1
mariadb-backup AlmaLinux:10All versions3:10.11.18-1.el10_2.alma.1
mariadb-client-utils AlmaLinux:10All versions3:10.11.18-1.el10_2.alma.1
mariadb-common AlmaLinux:10All versions3:10.11.18-1.el10_2.alma.1
mariadb-devel AlmaLinux:10All versions3:10.11.18-1.el10_2.alma.1
mariadb-embedded AlmaLinux:10All versions3:10.11.18-1.el10_2.alma.1
mariadb-embedded-devel AlmaLinux:10All versions3:10.11.18-1.el10_2.alma.1
mariadb-errmsg AlmaLinux:10All versions3:10.11.18-1.el10_2.alma.1
mariadb-gssapi-server AlmaLinux:10All versions3:10.11.18-1.el10_2.alma.1
mariadb-oqgraph-engine AlmaLinux:10All versions3:10.11.18-1.el10_2.alma.1
mariadb-pam AlmaLinux:10All versions3:10.11.18-1.el10_2.alma.1
mariadb-server AlmaLinux:10All versions3:10.11.18-1.el10_2.alma.1
mariadb-server-galera AlmaLinux:10All versions3:10.11.18-1.el10_2.alma.1
mariadb-server-utils AlmaLinux:10All versions3:10.11.18-1.el10_2.alma.1
mariadb-test AlmaLinux:10All versions3:10.11.18-1.el10_2.alma.1
mariadb11.8 AlmaLinux:10All versions3:11.8.8-1.el10_2
mariadb11.8-backup AlmaLinux:10All versions3:11.8.8-1.el10_2
mariadb11.8-client-utils AlmaLinux:10All versions3:11.8.8-1.el10_2
mariadb11.8-common AlmaLinux:10All versions3:11.8.8-1.el10_2
mariadb11.8-devel AlmaLinux:10All versions3:11.8.8-1.el10_2
mariadb11.8-embedded AlmaLinux:10All versions3:11.8.8-1.el10_2
mariadb11.8-embedded-devel AlmaLinux:10All versions3:11.8.8-1.el10_2
mariadb11.8-errmsg AlmaLinux:10All versions3:11.8.8-1.el10_2
mariadb11.8-gssapi-server AlmaLinux:10All versions3:11.8.8-1.el10_2
mariadb11.8-oqgraph-engine AlmaLinux:10All versions3:11.8.8-1.el10_2
mariadb11.8-pam AlmaLinux:10All versions3:11.8.8-1.el10_2
mariadb11.8-server AlmaLinux:10All versions3:11.8.8-1.el10_2
mariadb11.8-server-galera AlmaLinux:10All versions3:11.8.8-1.el10_2
mariadb11.8-server-utils AlmaLinux:10All versions3:11.8.8-1.el10_2
mariadb11.8-test AlmaLinux:10All versions3:11.8.8-1.el10_2
galera AlmaLinux:9All versions26.4.27-1.module_el9.8.0+274+ad8c02e7
galera AlmaLinux:9All versions26.4.27-1.module_el9.8.0+275+ff40c56f
galera AlmaLinux:9All versions26.4.27-1.module_el9.8.0+315+b08bed7e
mariadb AlmaLinux:9All versions3:10.11.18-1.module_el9.8.0+275+ff40c56f
mariadb AlmaLinux:9All versions3:10.11.18-1.module_el9.8.0+315+b08bed7e.alma.1
mariadb AlmaLinux:9All versions3:11.8.8-1.module_el9.8.0+274+ad8c02e7

Products include Mariadb Mariadb.

How do I fix CVE-2026-49261?

Upgrade mariadb to a fixed version for your release line: 10.6.27, 10.11.18, 11.4.12 or 11.8.8.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2026-49261 being exploited?

There is no known exploitation of CVE-2026-49261 in the wild and no public exploit code.

All Mariadb Mariadb vulnerabilities

Sources

Also known as ALSA-2026:33093, ALSA-2026:33412, ALSA-2026:33481, ALSA-2026:33482, BELL-CVE-2026-49261, BIT-mariadb-2026-49261 and 17 more.

Is CVE-2026-49261 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free