{"answers":{"affected":"2 open source packages ship an affected version, including aimeos/pagible.","exploited":"There is no known exploitation of CVE-2026-49262 in the wild and no public exploit code.","fix":"Upgrade aimeos/pagible to 0.10.4 or later.","what":"CVE-2026-49262 is a low-severity server-side request forgery vulnerability in aimeos pagible, published on 12 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-49262 and fix it if it is affected.\n\nWhat it is: CVE-2026-49262 is a low-severity server-side request forgery vulnerability in aimeos pagible, published on 12 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-49262 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- aimeos/pagible (Packagist): affected all versions; fixed in 0.10.4\n- aimeos/pagible (Packagist): affected all versions; fixed in 0.10.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-49262/ (Markdown: https://insights.sbomify.com/CVE-2026-49262/index.md)","id":"CVE-2026-49262","markdown":"https://insights.sbomify.com/CVE-2026-49262/index.md","name":"CVE-2026-49262","record":{"aliases":["GHSA-mmj8-wcvw-6789"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Aimeos Pagible CMS","requires_auth":"low_privilege","summary":"Attackers can exploit a race condition in the admin proxy to perform Server-Side Request Forgery, accessing internal network resources and cloud metadata.","user_interaction":"required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":3,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"},{"id":"CWE-367","name":"Time-of-check Time-of-use (TOCTOU) Race Condition"}],"description":"In the Aimeos Pagible content management system prior to version 0.10.4, the administrative proxy route (`cmsproxy`) is vulnerable to a Server-Side Request Forgery (SSRF) attack via DNS Rebinding. A Time-of-Check to Time-of-Use (TOCTOU) race condition exists between the URL validation phase and the actual HTTP request phase, allowing attackers to access internal network resources and cloud metadata endpoints. Version 0.10.4 fixes the issue.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Aimeos Pagible CMS vulnerable to Server Side Request Forgery (SSRF) via DNS rebinding in admin proxy","id":"CVE-2026-49262","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Capstone WASM `br_table` instruction-size truncation can cause no-progress disassembly and parser desynchronization","id":"CVE-2026-49263"},"packages":[{"ecosystem":"Packagist","fixed":["0.10.4"],"introduced":["0"],"last_affected":[],"package":"aimeos/pagible","purl":null,"source":"GHSA-mmj8-wcvw-6789"},{"ecosystem":"Packagist","fixed":["0.10.4"],"introduced":["0"],"last_affected":[],"package":"aimeos/pagible","purl":"pkg:composer/aimeos/pagible","source":"GHSA-mmj8-wcvw-6789"}],"prev":{"headline":"MariaDB server has unsafe parameter handling in `wsrep_notify_cmd`","id":"CVE-2026-49261"},"products":["pagible"],"published":"2026-08-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-12","vendors":["aimeos"]},"summary":"Attackers can exploit a race condition in the admin proxy to perform Server-Side Request Forgery, accessing internal network resources and cloud metadata.","url":"https://insights.sbomify.com/CVE-2026-49262/"}