# CVE-2026-49262: Aimeos Pagible CMS vulnerable to Server Side Request Forgery (SSRF) via DNS rebinding in admin proxy

> Attackers can exploit a race condition in the admin proxy to perform Server-Side Request Forgery, accessing internal network resources and cloud metadata.

- **Severity:** Low 3.0 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Aug 2026
- **Updated:** 12 Aug 2026
- **Also known as:** GHSA-mmj8-wcvw-6789

## What is CVE-2026-49262?

CVE-2026-49262 is a low-severity server-side request forgery vulnerability in aimeos pagible, published on 12 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

In the Aimeos Pagible content management system prior to version 0.10.4, the administrative proxy route (`cmsproxy`) is vulnerable to a Server-Side Request Forgery (SSRF) attack via DNS Rebinding. A Time-of-Check to Time-of-Use (TOCTOU) race condition exists between the URL validation phase and the actual HTTP request phase, allowing attackers to access internal network resources and cloud metadata endpoints. Version 0.10.4 fixes the issue.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-367 (Time-of-check Time-of-use (TOCTOU) Race Condition)

## Which versions are affected by CVE-2026-49262?

2 open source packages ship an affected version, including aimeos/pagible.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aimeos/pagible` | Packagist | All versions | 0.10.4 |
| `aimeos/pagible` | Packagist | All versions | 0.10.4 |

## How do I fix CVE-2026-49262?

Upgrade aimeos/pagible to 0.10.4 or later.

## Is CVE-2026-49262 being exploited?

There is no known exploitation of CVE-2026-49262 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49262 and fix it if it is affected.

What it is: CVE-2026-49262 is a low-severity server-side request forgery vulnerability in aimeos pagible, published on 12 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-49262 in the wild and no public exploit code.

Affected packages and fixed versions:
- aimeos/pagible (Packagist): affected all versions; fixed in 0.10.4
- aimeos/pagible (Packagist): affected all versions; fixed in 0.10.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49262/ (Markdown: https://insights.sbomify.com/CVE-2026-49262/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49262
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49262
- OSV: https://osv.dev/vulnerability/CVE-2026-49262

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49262/
Summaries are generated and may contain mistakes; the official description above is the record.
