# CVE-2026-49264: OAuthLib: Unsafe JSONP callback injection in RevocationEndpoint allows arbitrary JavaScript response generation

> Attacker-controlled JavaScript execution via unsafe JSONP callback injection in OAuthLib's RevocationEndpoint when JSONP is enabled.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Oct 2026
- **Updated:** 16 Oct 2026
- **Also known as:** AZL-108042, CLEANSTART-2026-JM52525, CLEANSTART-2026-PM64719, CLEANSTART-2026-UF47691, DEBIAN-CVE-2026-49264, ECHO-5e10-b8eb-8481, GHSA-hj66-6f7g-4r5v, MINI-2428-56jm-6fjw, MINI-492f-w55m-3ppg, MINI-4jx9-4px7-cwvm, MINI-5cf2-785h-gqpr, MINI-5cp5-9wvv-3h32, MINI-762j-vgwv-8mhp, MINI-96g5-qch4-2v94, MINI-994p-45wc-58cv, MINI-f82g-jfqq-cj4p, MINI-gwpf-6wxx-mh3r, MINI-j73w-9gcq-697p, MINI-mhvx-3xxg-q8p5, MINI-mmx7-66pj-q94r, MINI-p3rx-9pmf-g9gr, MINI-pchv-j4mm-q4pp, MINI-q445-2mxq-hrf4, MINI-r935-mc37-rr99, MINI-rj7p-qwh9-m78j, MINI-rp8q-cr94-gc9c, MINI-rr26-9fv7-2f6x, MINI-vq45-7cxq-f6j5, MINI-wwpm-37v2-v5c2, MINI-xgvm-53cj-fvvv, MINI-xhr6-xqhh-pv7c, OESA-2026-4497, OESA-2026-4498, OESA-2026-4499, OESA-2026-4500, PYSEC-2026-4113, SUSE-SU-2026:4807-1, UBUNTU-CVE-2026-49264, openSUSE-SU-2026:11973-1

## What is CVE-2026-49264?

CVE-2026-49264 is a medium-severity cross-site scripting vulnerability in oauthlib, published on 13 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

OAuthLib is an implementation of the OAuth request-signing logic for Python 3.6+. From 0.6.1 until 4.0.0, OAuthLib's RevocationEndpoint in oauthlib/oauth2/rfc6749/endpoints/revocation.py reflects an unvalidated callback request parameter into success and error response bodies when enable_jsonp=True. The callback can come from the query string or request body and is used without restricting it to a legal JavaScript function name. A browser application that loads the revocation response as trusted JSONP and permits attacker influence over callback can therefore execute attacker-controlled JavaScript in the including application's origin, with access to its DOM and script-accessible data. The feature is disabled by default, so only deployments that explicitly enable JSONP are affected. This issue is fixed in version 4.0.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-49264?

3 open source packages ship an affected version, including oauthlib.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `oauthlib` | PyPI | From 0.6.1 | 4.0.0 |
| `oauthlib` | PyPI | From 0.6.1 | 4.0.0 |
| `oauthlib` | PyPI | From 0.6.1 | 4.0.0 |
| `python-oauthlib` | SUSE:Linux Enterprise Micro 5.5 | All versions | 2.0.6-150000.3.9.1 |
| `python-oauthlib` | SUSE:Linux Enterprise Module for Basesystem 15 SP7 | All versions | 2.0.6-150000.3.9.1 |
| `python-oauthlib` | openSUSE:Tumbleweed | All versions | 4.0.0-1.1 |

## How do I fix CVE-2026-49264?

Upgrade oauthlib to 4.0.0 or later.

## Is CVE-2026-49264 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49264 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49264 and fix it if it is affected.

What it is: CVE-2026-49264 is a medium-severity cross-site scripting vulnerability in oauthlib, published on 13 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49264 exists.

Affected packages and fixed versions:
- oauthlib (PyPI): affected from 0.6.1; fixed in 4.0.0
- oauthlib (PyPI): affected from 0.6.1; fixed in 4.0.0
- oauthlib (PyPI): affected from 0.6.1; fixed in 4.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49264/ (Markdown: https://insights.sbomify.com/CVE-2026-49264/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49264
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49264
- OSV: https://osv.dev/vulnerability/CVE-2026-49264

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49264/
Summaries are generated and may contain mistakes; the official description above is the record.
