# CVE-2026-49267: Apache Airflow: No certificate validation on SMTP STARTTLS connections

> Attackers can intercept SMTP credentials and emails via MITM due to missing certificate validation in Airflow's STARTTLS connections.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jun 2026
- **Updated:** 2 Jun 2026
- **Also known as:** BIT-airflow-2026-49267, ECHO-b79a-0540-f5c0, GHSA-799x-qp47-8qwq, MINI-662r-jq93-25m5, MINI-r4xw-ww9f-f63j, PYSEC-2026-2346

## What is CVE-2026-49267?

CVE-2026-49267 is a medium-severity vulnerability in Apache Airflow, published on 1 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Airflow's EmailOperator and the underlying `airflow.utils.email` helpers established SMTP STARTTLS connections without verifying the remote certificate when the deployment used `[email] smtp_starttls=True` without `[email] smtp_ssl`. An attacker positioned between the worker and the configured SMTP server (network MITM — typical hostile-network attack-surface for environments where the SMTP relay sits outside the worker's trust boundary) could present a self-signed certificate, have the worker complete the STARTTLS handshake silently, and capture the SMTP AUTH credentials and message contents the worker forwarded.

This CVE covers the **core apache-airflow side** of the same root cause already covered for the SMTP provider by `CVE-2026-41016` (published 2026-04-27, covering `apache-airflow-providers-smtp`). Users who already applied the SMTP-provider fix from CVE-2026-41016 should additionally upgrade `apache-airflow` to 3.2.2 or later to cover the core-side path through `airflow.utils.email`. Affects deployments configured with `smtp_starttls=True` and `smtp_ssl=False` where the SMTP relay is reachable across a less-trusted network segment than the worker.

Users are advised to upgrade to `apache-airflow` 3.2.2 or later.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2026-49267?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | From 2.0.0 | 3.2.2 |
| `apache-airflow` | PyPI | From 2.0.0 | 3.2.2 |
| `apache-airflow` | PyPI | From 2.0.0 | 3.2.2 |
| `airflow` | Bitnami | From 2.0.0 | 3.2.2 |

Products: Apache Airflow.

## How do I fix CVE-2026-49267?

Upgrade apache-airflow to 3.2.2 or later.

## Is CVE-2026-49267 being exploited?

There is no known exploitation of CVE-2026-49267 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49267 and fix it if it is affected.

What it is: CVE-2026-49267 is a medium-severity vulnerability in Apache Airflow, published on 1 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-49267 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected from 2.0.0; fixed in 3.2.2
- apache-airflow (PyPI): affected from 2.0.0; fixed in 3.2.2
- apache-airflow (PyPI): affected from 2.0.0; fixed in 3.2.2
- airflow (Bitnami): affected from 2.0.0; fixed in 3.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49267/ (Markdown: https://insights.sbomify.com/CVE-2026-49267/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49267
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49267
- OSV: https://osv.dev/vulnerability/CVE-2026-49267

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49267/
Summaries are generated and may contain mistakes; the official description above is the record.
