# CVE-2026-49270: Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All have an Exposure of Sensitive Information Through Metadata vulnerability

> Unauthenticated attackers can disclose durable subscription details if network connectors are configured with syncDurableSubs enabled.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jun 2026
- **Updated:** 1 Jun 2026
- **Also known as:** BIT-activemq-2026-49270, DEBIAN-CVE-2026-49270, GHSA-hf52-78x8-6w3w, MINI-7w86-xx6j-7mpr, MINI-cp79-c43j-5jqg, MINI-rv7c-vx47-w2f5, MINI-w6j8-6hwv-cwgj, ROOT-APP-MAVEN-CVE-2026-49270, UBUNTU-CVE-2026-49270

## What is CVE-2026-49270?

CVE-2026-49270 is a medium-severity vulnerability in Apache Activemq, published on 1 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Exposure of Sensitive Information Through Metadata vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All.

Brokers that are configured with a network connector with syncDurableSubs set to true, are vulnerable to an unauthenticated attacker who can receive a list of all durable topic subscriptions in the broker, including client identifiers, subscription names, topic destinations, and JMS selector expressions, by sending a BrokerInfo command. The broker incorrectly responds without first ensuring the connection is authenticated.
This issue affects Apache ActiveMQ Broker: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ All: before 5.19.7, from 6.0.0 before 6.2.6.

Users are recommended to upgrade to version 6.2.6 or 5.19.7, which fixes the issue.

Weakness: CWE-1230 (Exposure of Sensitive Information Through Metadata)

## Which versions are affected by CVE-2026-49270?

13 open source packages ship an affected version, including org.apache.activemq:activemq-all, activemq and org.apache.activemq:activemq-broker. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.activemq:activemq-all` | Maven | All versions | 5.19.7 |
| `org.apache.activemq:activemq-all` | Maven | All versions | 5.19.7 |
| `org.apache.activemq:activemq-all` | Maven | From 6.0.0 | 6.2.6 |
| `org.apache.activemq:activemq-all` | Maven | From 6.0.0 | 6.2.6 |
| `activemq` | Bitnami | All versions | 5.19.7, 6.2.6 |
| `org.apache.activemq:activemq-broker` | Maven | All versions | 5.19.7 |
| `org.apache.activemq:activemq-broker` | Maven | All versions | 5.19.7 |
| `org.apache.activemq:activemq-broker` | Maven | From 6.0.0 | 6.2.6 |
| `org.apache.activemq:activemq-broker` | Maven | From 6.0.0 | 6.2.6 |
| `org.apache.activemq:apache-activemq` | Maven | All versions | 5.19.7 |
| `org.apache.activemq:apache-activemq` | Maven | All versions | 5.19.7 |
| `org.apache.activemq:apache-activemq` | Maven | From 6.0.0 | 6.2.6 |
| `org.apache.activemq:apache-activemq` | Maven | From 6.0.0 | 6.2.6 |

Products: Apache Activemq, Apache Activemq Broker.

## How do I fix CVE-2026-49270?

Upgrade org.apache.activemq:activemq-all to a fixed version for your release line: 5.19.7 or 6.2.6.

## Is CVE-2026-49270 being exploited?

There is no known exploitation of CVE-2026-49270 in the wild and no public exploit code.

## Other vulnerabilities in Apache Activemq

- [CVE-2023-46604](https://insights.sbomify.com/CVE-2023-46604/): Apache ActiveMQ Deserialization of Untrusted Data (critical 10.0, exploited in the wild)
- [CVE-2016-3088](https://insights.sbomify.com/CVE-2016-3088/): Apache ActiveMQ Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2026-34197](https://insights.sbomify.com/CVE-2026-34197/): Apache ActiveMQ Improper Input Validation (high 8.8, exploited in the wild)
- [CVE-2020-11998](https://insights.sbomify.com/CVE-2020-11998/): Remote code execution in Apache ActiveMQ (critical 9.8)
- [CVE-2013-7285](https://insights.sbomify.com/CVE-2013-7285/): Command Injection in Xstream (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49270 and fix it if it is affected.

What it is: CVE-2026-49270 is a medium-severity vulnerability in Apache Activemq, published on 1 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-49270 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.activemq:activemq-all (Maven): affected all versions; fixed in 5.19.7
- org.apache.activemq:activemq-all (Maven): affected all versions; fixed in 5.19.7
- org.apache.activemq:activemq-all (Maven): affected from 6.0.0; fixed in 6.2.6
- org.apache.activemq:activemq-all (Maven): affected from 6.0.0; fixed in 6.2.6
- activemq (Bitnami): affected all versions; fixed in 5.19.7, 6.2.6
- org.apache.activemq:activemq-broker (Maven): affected all versions; fixed in 5.19.7
- org.apache.activemq:activemq-broker (Maven): affected all versions; fixed in 5.19.7
- org.apache.activemq:activemq-broker (Maven): affected from 6.0.0; fixed in 6.2.6
- org.apache.activemq:activemq-broker (Maven): affected from 6.0.0; fixed in 6.2.6
- org.apache.activemq:apache-activemq (Maven): affected all versions; fixed in 5.19.7
- org.apache.activemq:apache-activemq (Maven): affected all versions; fixed in 5.19.7
- org.apache.activemq:apache-activemq (Maven): affected from 6.0.0; fixed in 6.2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49270/ (Markdown: https://insights.sbomify.com/CVE-2026-49270/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49270
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49270
- OSV: https://osv.dev/vulnerability/CVE-2026-49270

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49270/
Summaries are generated and may contain mistakes; the official description above is the record.
