# CVE-2026-49274: Kirby: `pages.access` permission is not checked in the pages picker for parent pages

> Authenticated users can bypass page access restrictions to confirm existence and retrieve titles of inaccessible parent pages in Kirby CMS.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jul 2026
- **Updated:** 14 Jul 2026
- **Also known as:** GHSA-23q2-54qv-rq5x

## What is CVE-2026-49274?

CVE-2026-49274 is a medium-severity missing authorization vulnerability in getkirby kirby, published on 9 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Kirby is an open-source content management system. Prior to 4.9.4 and 5.4.4, Kirby sites using the pages field with roles that have the pages.access permission disabled allowed authenticated users to provide an inaccessible parent page or site to the page picker backend and confirm arbitrary page existence and retrieve title field values. This issue is fixed in versions 4.9.4 and 5.4.4.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-49274?

4 open source packages ship an affected version, including getkirby/cms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getkirby/cms` | Packagist | All versions | 4.9.4 |
| `getkirby/cms` | Packagist | All versions | 4.9.4 |
| `getkirby/cms` | Packagist | From 5.0.0-alpha.1 | 5.4.4 |
| `getkirby/cms` | Packagist | From 5.0.0-alpha.1 | 5.4.4 |

## How do I fix CVE-2026-49274?

Upgrade getkirby/cms to a fixed version for your release line: 4.9.4 or 5.4.4.

## Is CVE-2026-49274 being exploited?

There is no known exploitation of CVE-2026-49274 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49274 and fix it if it is affected.

What it is: CVE-2026-49274 is a medium-severity missing authorization vulnerability in getkirby kirby, published on 9 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-49274 in the wild and no public exploit code.

Affected packages and fixed versions:
- getkirby/cms (Packagist): affected all versions; fixed in 4.9.4
- getkirby/cms (Packagist): affected all versions; fixed in 4.9.4
- getkirby/cms (Packagist): affected from 5.0.0-alpha.1; fixed in 5.4.4
- getkirby/cms (Packagist): affected from 5.0.0-alpha.1; fixed in 5.4.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49274/ (Markdown: https://insights.sbomify.com/CVE-2026-49274/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49274
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49274
- OSV: https://osv.dev/vulnerability/CVE-2026-49274

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49274/
Summaries are generated and may contain mistakes; the official description above is the record.
