CVE-2026-49276 Kirby: Self cross-site scripting (self-XSS) in the writer field
Attackers can inject malicious scripts via writer field links, enabling self-XSS in the Kirby CMS Panel.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-49276?
CVE-2026-49276 is a high-severity cross-site scripting vulnerability in getkirby kirby, published on 9 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Kirby is an open-source content management system. Prior to 4.9.4 and 5.4.4, Kirby sites using the writer field in any blueprint allowed a scripting link to be included as the target of a link or email link in writer mark components, making the target clickable by the user who entered it and enabling self cross-site scripting in the Panel. This issue is fixed in versions 4.9.4 and 5.4.4.
Weakness: CWE-83
Which versions are affected by CVE-2026-49276?
4 open source packages ship an affected version, including getkirby/cms.
| Package | Affected | Fixed in |
|---|---|---|
getkirby/cms Packagist | All versions | 4.9.4 |
getkirby/cms Packagist | All versions | 4.9.4 |
getkirby/cms Packagist | From 5.0.0-alpha.1 | 5.4.4 |
getkirby/cms Packagist | From 5.0.0-alpha.1 | 5.4.4 |
How do I fix CVE-2026-49276?
Upgrade getkirby/cms to a fixed version for your release line: 4.9.4 or 5.4.4.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-49276 being exploited?
There is no known exploitation of CVE-2026-49276 in the wild and no public exploit code.
Sources
Also known as GHSA-rhj6-r49h-5932.