{"answers":{"affected":"4 open source packages ship an affected version, including getkirby/cms.","exploited":"There is no known exploitation of CVE-2026-49276 in the wild and no public exploit code.","fix":"Upgrade getkirby/cms to a fixed version for your release line: 4.9.4 or 5.4.4.","what":"CVE-2026-49276 is a high-severity cross-site scripting vulnerability in getkirby kirby, published on 9 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-49276 and fix it if it is affected.\n\nWhat it is: CVE-2026-49276 is a high-severity cross-site scripting vulnerability in getkirby kirby, published on 9 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-49276 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- getkirby/cms (Packagist): affected all versions; fixed in 4.9.4\n- getkirby/cms (Packagist): affected all versions; fixed in 4.9.4\n- getkirby/cms (Packagist): affected from 5.0.0-alpha.1; fixed in 5.4.4\n- getkirby/cms (Packagist): affected from 5.0.0-alpha.1; fixed in 5.4.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-49276/ (Markdown: https://insights.sbomify.com/CVE-2026-49276/index.md)","id":"CVE-2026-49276","markdown":"https://insights.sbomify.com/CVE-2026-49276/index.md","name":"CVE-2026-49276","record":{"aliases":["GHSA-rhj6-r49h-5932"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Kirby CMS","requires_auth":"none","summary":"Attackers can inject malicious scripts via writer field links, enabling self-XSS in the Kirby CMS Panel.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.4,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-83","name":"Improper Neutralization of Script in Attributes in a Web Page"}],"description":"Kirby is an open-source content management system. Prior to 4.9.4 and 5.4.4, Kirby sites using the writer field in any blueprint allowed a scripting link to be included as the target of a link or email link in writer mark components, making the target clickable by the user who entered it and enabling self cross-site scripting in the Panel. This issue is fixed in versions 4.9.4 and 5.4.4.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Kirby: Self cross-site scripting (self-XSS) in the writer field","id":"CVE-2026-49276","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":4,"n_references":3,"next":{"headline":"Rocket.Chat: OAuth access and refresh tokens remain valid after account deactivation","id":"CVE-2026-49277"},"packages":[{"ecosystem":"Packagist","fixed":["4.9.4"],"introduced":["0"],"last_affected":[],"package":"getkirby/cms","purl":null,"source":"GHSA-rhj6-r49h-5932"},{"ecosystem":"Packagist","fixed":["4.9.4"],"introduced":["0"],"last_affected":[],"package":"getkirby/cms","purl":"pkg:composer/getkirby/cms","source":"GHSA-rhj6-r49h-5932"},{"ecosystem":"Packagist","fixed":["5.4.4"],"introduced":["5.0.0-alpha.1"],"last_affected":[],"package":"getkirby/cms","purl":null,"source":"GHSA-rhj6-r49h-5932"},{"ecosystem":"Packagist","fixed":["5.4.4"],"introduced":["5.0.0-alpha.1"],"last_affected":[],"package":"getkirby/cms","purl":"pkg:composer/getkirby/cms","source":"GHSA-rhj6-r49h-5932"}],"prev":{"headline":"Kirby: `pages.access` permission is not checked in the pages picker for parent pages","id":"CVE-2026-49274"},"products":["kirby"],"published":"2026-07-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-10","vendors":["getkirby"]},"summary":"Attackers can inject malicious scripts via writer field links, enabling self-XSS in the Kirby CMS Panel.","url":"https://insights.sbomify.com/CVE-2026-49276/"}