# CVE-2026-49276: Kirby: Self cross-site scripting (self-XSS) in the writer field

> Attackers can inject malicious scripts via writer field links, enabling self-XSS in the Kirby CMS Panel.

- **Severity:** High 7.4 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Jul 2026
- **Updated:** 10 Jul 2026
- **Also known as:** GHSA-rhj6-r49h-5932

## What is CVE-2026-49276?

CVE-2026-49276 is a high-severity cross-site scripting vulnerability in getkirby kirby, published on 9 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Kirby is an open-source content management system. Prior to 4.9.4 and 5.4.4, Kirby sites using the writer field in any blueprint allowed a scripting link to be included as the target of a link or email link in writer mark components, making the target clickable by the user who entered it and enabling self cross-site scripting in the Panel. This issue is fixed in versions 4.9.4 and 5.4.4.

Weakness: CWE-83 (Improper Neutralization of Script in Attributes in a Web Page)

## Which versions are affected by CVE-2026-49276?

4 open source packages ship an affected version, including getkirby/cms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getkirby/cms` | Packagist | All versions | 4.9.4 |
| `getkirby/cms` | Packagist | All versions | 4.9.4 |
| `getkirby/cms` | Packagist | From 5.0.0-alpha.1 | 5.4.4 |
| `getkirby/cms` | Packagist | From 5.0.0-alpha.1 | 5.4.4 |

## How do I fix CVE-2026-49276?

Upgrade getkirby/cms to a fixed version for your release line: 4.9.4 or 5.4.4.

## Is CVE-2026-49276 being exploited?

There is no known exploitation of CVE-2026-49276 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49276 and fix it if it is affected.

What it is: CVE-2026-49276 is a high-severity cross-site scripting vulnerability in getkirby kirby, published on 9 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-49276 in the wild and no public exploit code.

Affected packages and fixed versions:
- getkirby/cms (Packagist): affected all versions; fixed in 4.9.4
- getkirby/cms (Packagist): affected all versions; fixed in 4.9.4
- getkirby/cms (Packagist): affected from 5.0.0-alpha.1; fixed in 5.4.4
- getkirby/cms (Packagist): affected from 5.0.0-alpha.1; fixed in 5.4.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49276/ (Markdown: https://insights.sbomify.com/CVE-2026-49276/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49276
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49276
- OSV: https://osv.dev/vulnerability/CVE-2026-49276

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49276/
Summaries are generated and may contain mistakes; the official description above is the record.
