# CVE-2026-49283: SimpleSAMLphp HTTP-Artifact TLS validator confusion allows cross-IdP authentication bypass

> A malicious identity provider can bypass authentication in SimpleSAMLphp by exploiting TLS validator confusion, allowing arbitrary user impersonation in multi-IdP federations.

- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Aug 2026
- **Updated:** 19 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-49283, GHSA-6929-8p9f-26jx, UBUNTU-CVE-2026-49283

## What is CVE-2026-49283?

CVE-2026-49283 is a high-severity authentication bypass vulnerability in simplesamlphp saml2, published on 19 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

The SimpleSAMLphp SAML2 library is a PHP library for SAML2 related functionality. Prior to versions 4.19.3, 4.20.2, 5.0.6, and 6.2.1, the HTTPArtifact::receive() flow can treat an unsigned embedded SAML Response as cryptographically valid for the wrong identity provider. SOAPClient::addSSLValidator() attaches a TLS-based validator to the outer SOAP ArtifactResponse, while the embedded Response receives a validator that delegates to the outer message and is later checked against metadata selected from the embedded response issuer rather than necessarily the artifact issuer. SOAPClient::validateSSL() returns normally when the TLS public key does not match the key being validated, and SAML2\Message::validate() treats a validator call that does not throw as successful. In a multi-IdP federation, a malicious or lower-trust IdP can therefore provide an ArtifactResponse containing an unsigned Response that claims a higher-trust victim IdP as issuer and authenticate as arbitrary users with attacker-chosen assertion attributes, NameID, and session data. This issue is fixed in versions 4.19.3, 4.20.2, 5.0.6, and 6.2.1.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2026-49283?

12 open source packages ship an affected version, including simplesamlphp/saml2 and simplesamlphp/saml2-legacy.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `simplesamlphp/saml2` | Packagist | All versions | 4.19.3 |
| `simplesamlphp/saml2` | Packagist | All versions | 4.19.3 |
| `simplesamlphp/saml2` | Packagist | From 4.20.0 | 4.20.2 |
| `simplesamlphp/saml2` | Packagist | From 4.20.0 | 4.20.2 |
| `simplesamlphp/saml2` | Packagist | From 5.0.0 | 5.0.6 |
| `simplesamlphp/saml2` | Packagist | From 5.0.0 | 5.0.6 |
| `simplesamlphp/saml2` | Packagist | From 6.0.0 | 6.2.1 |
| `simplesamlphp/saml2` | Packagist | From 6.0.0 | 6.2.1 |
| `simplesamlphp/saml2-legacy` | Packagist | All versions | 4.19.3 |
| `simplesamlphp/saml2-legacy` | Packagist | All versions | 4.19.3 |
| `simplesamlphp/saml2-legacy` | Packagist | From 4.20.0 | 4.20.2 |
| `simplesamlphp/saml2-legacy` | Packagist | From 4.20.0 | 4.20.2 |

## How do I fix CVE-2026-49283?

Upgrade simplesamlphp/saml2 to a fixed version for your release line: 4.19.3, 4.20.2, 5.0.6 or 6.2.1.

## Is CVE-2026-49283 being exploited?

There is no known exploitation of CVE-2026-49283 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49283 and fix it if it is affected.

What it is: CVE-2026-49283 is a high-severity authentication bypass vulnerability in simplesamlphp saml2, published on 19 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-49283 in the wild and no public exploit code.

Affected packages and fixed versions:
- simplesamlphp/saml2 (Packagist): affected all versions; fixed in 4.19.3
- simplesamlphp/saml2 (Packagist): affected all versions; fixed in 4.19.3
- simplesamlphp/saml2 (Packagist): affected from 4.20.0; fixed in 4.20.2
- simplesamlphp/saml2 (Packagist): affected from 4.20.0; fixed in 4.20.2
- simplesamlphp/saml2 (Packagist): affected from 5.0.0; fixed in 5.0.6
- simplesamlphp/saml2 (Packagist): affected from 5.0.0; fixed in 5.0.6
- simplesamlphp/saml2 (Packagist): affected from 6.0.0; fixed in 6.2.1
- simplesamlphp/saml2 (Packagist): affected from 6.0.0; fixed in 6.2.1
- simplesamlphp/saml2-legacy (Packagist): affected all versions; fixed in 4.19.3
- simplesamlphp/saml2-legacy (Packagist): affected all versions; fixed in 4.19.3
- simplesamlphp/saml2-legacy (Packagist): affected from 4.20.0; fixed in 4.20.2
- simplesamlphp/saml2-legacy (Packagist): affected from 4.20.0; fixed in 4.20.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49283/ (Markdown: https://insights.sbomify.com/CVE-2026-49283/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49283
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49283
- OSV: https://osv.dev/vulnerability/CVE-2026-49283

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49283/
Summaries are generated and may contain mistakes; the official description above is the record.
