# CVE-2026-49284: SimpleSAMLphp SP accepts a response from an unexpected IdP when unsigned `Response/InResponseTo` is combined with a signed assertion lacking `SubjectConfirmationData/InResponseTo`

> Attackers can bypass IdP selection controls in SimpleSAMLphp by exploiting SAML response validation flaws, potentially accessing unauthorized data.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jul 2026
- **Updated:** 20 Jul 2026
- **Also known as:** DEBIAN-CVE-2026-49284, GHSA-q8r6-xj3f-wrrm, UBUNTU-CVE-2026-49284

## What is CVE-2026-49284?

CVE-2026-49284 is a high-severity authentication bypass vulnerability in simplesamlphp, published on 17 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

SimpleSAMLphp versions before 1.18.6 contain an information disclosure vulnerability. Prior to 2.4.7 and 2.5.2, SimpleSAMLphp's SAML SP ACS path does not enforce the IdP selected for an SP-initiated login when unsigned Response/InResponseTo is combined with a signed assertion lacking SubjectConfirmationData/InResponseTo, allowing a response issued by one trusted IdP to be bound to SP state created for another IdP and bypass flows that route users to a specific IdP, including deployments that set enable_unsolicited to false. This issue is fixed in versions 2.4.7 and 2.5.2.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2026-49284?

4 open source packages ship an affected version, including simplesamlphp/simplesamlphp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `simplesamlphp/simplesamlphp` | Packagist | All versions | 2.4.7 |
| `simplesamlphp/simplesamlphp` | Packagist | All versions | 2.4.7 |
| `simplesamlphp/simplesamlphp` | Packagist | From 2.5.0 | 2.5.2 |
| `simplesamlphp/simplesamlphp` | Packagist | From 2.5.0 | 2.5.2 |

Products: Simplesamlphp Simplesamlphp.

## How do I fix CVE-2026-49284?

Upgrade simplesamlphp/simplesamlphp to a fixed version for your release line: 2.4.7 or 2.5.2.

## Is CVE-2026-49284 being exploited?

There is no known exploitation of CVE-2026-49284 in the wild and no public exploit code.

## Other vulnerabilities in simplesamlphp

- [CVE-2017-12868](https://insights.sbomify.com/CVE-2017-12868/): SimpleSAMLphp Session fixation issue and authentication bypass in the authcrypt module (critical 9.8)
- [CVE-2018-7644](https://insights.sbomify.com/CVE-2018-7644/): SimpleSAMLphp Improper Verification of Cryptographic Signature (high 7.5)
- [CVE-2018-6520](https://insights.sbomify.com/CVE-2018-6520/): SimpleSAMLphp Open redirection protection bypass (medium 6.1)
- [CVE-2017-12870](https://insights.sbomify.com/CVE-2017-12870/): SimpleSAMLphp Unauthenticated encryption in CBC mode (medium 5.9)
- [CVE-2017-12871](https://insights.sbomify.com/CVE-2017-12871/): SimpleSAMLphp Incorrect IV generation for encryption (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49284 and fix it if it is affected.

What it is: CVE-2026-49284 is a high-severity authentication bypass vulnerability in simplesamlphp, published on 17 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-49284 in the wild and no public exploit code.

Affected packages and fixed versions:
- simplesamlphp/simplesamlphp (Packagist): affected all versions; fixed in 2.4.7
- simplesamlphp/simplesamlphp (Packagist): affected all versions; fixed in 2.4.7
- simplesamlphp/simplesamlphp (Packagist): affected from 2.5.0; fixed in 2.5.2
- simplesamlphp/simplesamlphp (Packagist): affected from 2.5.0; fixed in 2.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49284/ (Markdown: https://insights.sbomify.com/CVE-2026-49284/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49284
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49284
- OSV: https://osv.dev/vulnerability/CVE-2026-49284

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49284/
Summaries are generated and may contain mistakes; the official description above is the record.
