CVE-2026-49287 Statamic CMS vulnerable to unsafe method invocation via collection sorting allows data destruction
Attackers can destroy content and assets via unsafe method invocation in collection sorting if templates pass user input to sort parameters.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-49287?
CVE-2026-49287 is a high-severity code injection vulnerability in statamic cms, published on 19 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Statamic is a Laravel and Git powered content management system (CMS). Prior to 5.73.23 and 6.20.0, the fix for CVE-2026-41175 was incomplete. It addressed the issue in the query builder, but the same protection was not applied to in-memory collection sorting. Manipulating sort parameters could result in the loss of content and assets. This requires a front-end template that passes request input into a tag's sort parameter. It is not exploitable by default — a template would need to be explicitly set up to sort by a visitor-controlled value. This has been fixed in 5.73.23 and 6.20.0.
Weakness: CWE-470
Which versions are affected by CVE-2026-49287?
4 open source packages ship an affected version, including statamic/cms.
| Package | Affected | Fixed in |
|---|---|---|
statamic/cms Packagist | All versions | 5.73.23 |
statamic/cms Packagist | All versions | 5.73.23 |
statamic/cms Packagist | From 6.0.0 | 6.20.0 |
statamic/cms Packagist | From 6.0.0 | 6.20.0 |
How do I fix CVE-2026-49287?
Upgrade statamic/cms to a fixed version for your release line: 5.73.23 or 6.20.0.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-49287 being exploited?
There is no known exploitation of CVE-2026-49287 in the wild and no public exploit code.
Sources
Also known as GHSA-m92m-r54r-x8r2.