# CVE-2026-49297: Apache Airflow Google provider allows path traversal through GCS object names

> Attackers with write access to source GCS buckets can use path traversal in object names to overwrite arbitrary files on SFTP servers or worker hosts.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jul 2026
- **Updated:** 6 Jul 2026
- **Also known as:** ECHO-1108-d5d4-edfc, GHSA-v3mh-27qj-w836, MINI-3r62-9p97-96r7, MINI-67p7-wp4p-75px, PYSEC-2026-2084

## What is CVE-2026-49297?

CVE-2026-49297 is a high-severity path traversal vulnerability in Apache Airflow Google provider, published on 6 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache Airflow's Google provider operators `GCSToSFTPOperator` and `GCSTimeSpanFileTransformOperator` joined GCS object names returned by the bucket listing API directly to a destination filesystem path without normalisation or containment check. A user with write access to the source GCS bucket (typically a different trust principal than the DAG author — partner uploads, ingest-only service accounts, public-data buckets) could create an object whose name contains `..` segments and cause the DAG run to write the downloaded blob outside the configured destination (the SFTP `destination_path` for `GCSToSFTPOperator`; the worker-local temp directory for `GCSTimeSpanFileTransformOperator`), enabling overwrite of arbitrary files on the SFTP server or the worker host. Affects deployments that ingest from buckets writable by less-trusted principals. Users are advised to upgrade to `apache-airflow-providers-google` 22.2.1 or later.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-49297?

3 open source packages ship an affected version, including apache-airflow-providers-google. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow-providers-google` | PyPI | All versions | 22.2.1 |
| `apache-airflow-providers-google` | PyPI | All versions | 22.2.1 |
| `apache-airflow-providers-google` | PyPI | All versions | 22.2.1 |

Products: Apache Apache-Airflow-Providers-Google.

## How do I fix CVE-2026-49297?

Upgrade apache-airflow-providers-google to 22.2.1 or later.

## Is CVE-2026-49297 being exploited?

There is no known exploitation of CVE-2026-49297 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow Google provider

- [CVE-2023-25691](https://insights.sbomify.com/CVE-2023-25691/): Apache Airflow Google Provider: Google Cloud Sql Provider Remote Command Execution (critical 9.8)
- [CVE-2026-45361](https://insights.sbomify.com/CVE-2026-45361/): Apache Airflow providers-google's `ComputeEngineSSHHook` disables SSH host-key verification by default (high 8.1)
- [CVE-2023-25692](https://insights.sbomify.com/CVE-2023-25692/): Apache Airflow Google Provider: Google Cloud Sql Provider Denial Of Service (high 7.5)
- [CVE-2026-68868](https://insights.sbomify.com/CVE-2026-68868/): Missing authorization in Apache Airflow Google provider (medium 6.5)
- [CVE-2026-81914](https://insights.sbomify.com/CVE-2026-81914/): Apache Airflow Google provider: Google Drive query injection via unescaped file and folder names (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49297 and fix it if it is affected.

What it is: CVE-2026-49297 is a high-severity path traversal vulnerability in Apache Airflow Google provider, published on 6 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-49297 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow-providers-google (PyPI): affected all versions; fixed in 22.2.1
- apache-airflow-providers-google (PyPI): affected all versions; fixed in 22.2.1
- apache-airflow-providers-google (PyPI): affected all versions; fixed in 22.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49297/ (Markdown: https://insights.sbomify.com/CVE-2026-49297/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49297
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49297
- OSV: https://osv.dev/vulnerability/CVE-2026-49297

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49297/
Summaries are generated and may contain mistakes; the official description above is the record.
