CVE-2026-49298 Apache Airflow: JWT Token Exposure in KubernetesExecutor Command-Line Arguments

High 8.8 Published Updated

Authenticated users with Kubernetes read access can extract JWT tokens from pod specs to impersonate workers and modify workflow data.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-49298?

CVE-2026-49298 is a high-severity vulnerability in Apache Airflow, published on 1 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A bug in Apache Airflow's KubernetesExecutor caused JWT tokens used by worker pods to authenticate against the Execution API to be passed to the worker container as command-line arguments visible in the pod spec. An authenticated UI/API user with Kubernetes read-only access to the cluster (e.g. `pods/get` in the Airflow namespace) could harvest the JWT from `kubectl describe pod` output and then call state-mutating Execution API endpoints — triggering Dag runs, clearing runs, reading or writing Variables / Connections / XComs — as if they were a running task. Affects deployments using the `KubernetesExecutor`. Users are advised to upgrade to `apache-airflow` 3.2.2 or later. This is the airflow-core half of the same vulnerability addressed by [CVE-2026-27173](https://www.cve.org/CVERecord?id=CVE-2026-27173), which shipped the apache-airflow-providers-cncf-kubernetes side of the fix. Deployments that already upgraded `apache-airflow-providers-cncf-kubernetes` to 10.17.0 or later per the CVE-2026-27173 advisory should additionally upgrade `apache-airflow` to 3.2.2 or later to close the core-side surface — the two fixes are complementary, not duplicates.

Weakness: CWE-538

Which versions are affected by CVE-2026-49298?

4 open source packages ship an affected version, including apache-airflow-core and airflow. It affects 1 product.

PackageAffectedFixed in
apache-airflow-core PyPIAll versions3.2.2
apache-airflow-core PyPIAll versions3.2.2
apache-airflow-core PyPIAll versions3.2.2
airflow BitnamiAll versions3.2.2

Products include Apache Airflow.

How do I fix CVE-2026-49298?

Upgrade apache-airflow-core to 3.2.2 or later.

Is CVE-2026-49298 being exploited?

There is no known exploitation of CVE-2026-49298 in the wild and no public exploit code.

All Apache Airflow vulnerabilities

Sources

Also known as BIT-airflow-2026-49298, ECHO-d5b1-8a54-bb7b, GHSA-5j6p-jrrm-6x94, MINI-x9xq-mxvv-5c79, PYSEC-2026-2358.

Is CVE-2026-49298 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free