# CVE-2026-49298: Apache Airflow: JWT Token Exposure in KubernetesExecutor Command-Line Arguments

> Authenticated users with Kubernetes read access can extract JWT tokens from pod specs to impersonate workers and modify workflow data.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jun 2026
- **Updated:** 2 Jun 2026
- **Also known as:** BIT-airflow-2026-49298, ECHO-d5b1-8a54-bb7b, GHSA-5j6p-jrrm-6x94, MINI-x9xq-mxvv-5c79, PYSEC-2026-2358

## What is CVE-2026-49298?

CVE-2026-49298 is a high-severity vulnerability in Apache Airflow, published on 1 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A bug in Apache Airflow's KubernetesExecutor caused JWT tokens used by worker pods to authenticate against the Execution API to be passed to the worker container as command-line arguments visible in the pod spec. An authenticated UI/API user with Kubernetes read-only access to the cluster (e.g. `pods/get` in the Airflow namespace) could harvest the JWT from `kubectl describe pod` output and then call state-mutating Execution API endpoints — triggering Dag runs, clearing runs, reading or writing Variables / Connections / XComs — as if they were a running task. Affects deployments using the `KubernetesExecutor`. Users are advised to upgrade to `apache-airflow` 3.2.2 or later. This is the airflow-core half of the same vulnerability addressed by [CVE-2026-27173](https://www.cve.org/CVERecord?id=CVE-2026-27173), which shipped the apache-airflow-providers-cncf-kubernetes side of the fix. Deployments that already upgraded `apache-airflow-providers-cncf-kubernetes` to 10.17.0 or later per the CVE-2026-27173 advisory should additionally upgrade `apache-airflow` to 3.2.2 or later to close the core-side surface — the two fixes are complementary, not duplicates.

Weakness: CWE-538 (Insertion of Sensitive Information into Externally-Accessible File or Directory)

## Which versions are affected by CVE-2026-49298?

4 open source packages ship an affected version, including apache-airflow-core and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow-core` | PyPI | All versions | 3.2.2 |
| `apache-airflow-core` | PyPI | All versions | 3.2.2 |
| `apache-airflow-core` | PyPI | All versions | 3.2.2 |
| `airflow` | Bitnami | All versions | 3.2.2 |

Products: Apache Airflow.

## How do I fix CVE-2026-49298?

Upgrade apache-airflow-core to 3.2.2 or later.

## Is CVE-2026-49298 being exploited?

There is no known exploitation of CVE-2026-49298 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49298 and fix it if it is affected.

What it is: CVE-2026-49298 is a high-severity vulnerability in Apache Airflow, published on 1 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-49298 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow-core (PyPI): affected all versions; fixed in 3.2.2
- apache-airflow-core (PyPI): affected all versions; fixed in 3.2.2
- apache-airflow-core (PyPI): affected all versions; fixed in 3.2.2
- airflow (Bitnami): affected all versions; fixed in 3.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49298/ (Markdown: https://insights.sbomify.com/CVE-2026-49298/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49298
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49298
- OSV: https://osv.dev/vulnerability/CVE-2026-49298

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49298/
Summaries are generated and may contain mistakes; the official description above is the record.
